summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 7 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3cfc053b499d..cafe72cd127d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,30 @@
# Maintainer: wolftankk <wolftankk@gmail.com>
pkgname=zephir
-pkgver=0.10.7
+pkgver=0.11.12
pkgrel=1
pkgdesc="Zephir is a compiled high level language aimed to the creation of C-extensions for PHP http://zephir-lang.com/"
url="https://github.com/phalcon/zephir"
arch=('x86_64' 'i686')
license=('MIT')
-depends=('re2c' 'json-c' 'php-zephir-parser')
-makedepends=('php' 'gcc' 'pcre')
-backup=('etc/php/conf.d/zephir.ini')
+depends=('php-zephir-parser')
+makedepends=('php')
if [[ $CARCH = "i686" ]]; then
makedepends+=('lib32-pcre');
fi
source=(
- "https://github.com/phalcon/zephir/archive/$pkgver.tar.gz"
+ "https://github.com/phalcon/zephir/releases/download/${pkgver}/zephir.phar"
)
-sha256sums=('b8402d971908e1e64b8b0e24bb5729bb142ea68824b8c754a6de9b91074693d3')
+sha256sums=('9224a5f3429d2565948dc2d1a6c1f467268c103b9205d01f277608c64bf514e2')
package() {
ZEPHIRDIR=/opt/$pkgname
- cd "$srcdir/zephir-$pkgver"
- sed "s#%ZEPHIRDIR%#$ZEPHIRDIR#g" bin/zephir > bin/zephir-cmd
- #init
install -d $pkgdir/{$ZEPHIRDIR,usr/bin}
- install -Dm777 bin/zephir-cmd "$pkgdir"/opt/zephir/bin/zephir
- install -Dm777 compiler.php "$pkgdir"/opt/zephir/compiler.php
- install -Dm777 bootstrap.php "$pkgdir"/opt/zephir/bootstrap.php
- cp -a kernels "$pkgdir"/opt/zephir/kernels
- cp -a Library "$pkgdir"/opt/zephir/Library
- cp -a prototypes "$pkgdir"/opt/zephir/prototypes
- cp -a runtime "$pkgdir"/opt/zephir/runtime
- cp -a templates "$pkgdir"/opt/zephir/templates
+ install -Dm777 zephir.phar "$pkgdir"/opt/zephir/zephir
- ln -s /opt/zephir/bin/zephir $pkgdir/usr/bin/zephir
-
- echo open_basedir=$(php -r "echo ini_get('open_basedir');"):/opt/zephir > zephir.ini
- install -Dm644 zephir.ini "$pkgdir"/etc/php/conf.d/zephir.ini
-
- if [ -d "/usr/share/bash-completion/completions" ]; then
- install -Dm644 bin/bash_completion "$pkgdir"/usr/share/bash-completion/completions/zephir
- fi
-
- msg2 "Please add '/opt/zephir' into 'open_basedir' in 'php.ini'"
+ ln -s /opt/zephir/zephir $pkgdir/usr/bin/zephir
}