summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2088ee9fdf6..9e4faa1f073b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Contributor: Kyle Keen <keenerd@gmail.com>
# Maintainer: Jakob <grandchild@gmx.net>
-pkgname=zeromq-draft
+
_pkgname=zeromq
-pkgver=4.3.2
-_cppver=4.4.1
-pkgrel=2
+pkgname=${_pkgname}-draft
+pkgver=4.3.3
+_cppver=4.7.1
+pkgrel=1
pkgdesc="Fast messaging system built on sockets. C and C++ bindings. aka 0MQ, ZMQ. With draft APIs."
arch=('x86_64')
url="http://www.zeromq.org"
@@ -14,21 +15,15 @@ makedepends=('asciidoc' 'xmlto')
conflicts=('zeromq')
options=('staticlibs')
# "http://download.zeromq.org/$_pkgname-$pkgver.tar.gz"
-source=("https://github.com/zeromq/libzmq/releases/download/v$pkgver/zeromq-$pkgver.tar.gz"
- "zmq.hpp.$pkgver.tgz::https://github.com/zeromq/cppzmq/archive/v$_cppver.tar.gz")
- #"zmq.hpp.$pkgver::https://raw.githubusercontent.com/zeromq/cppzmq/b0e6d4b/zmq.hpp")
-sha256sums=('ebd7b5c830d6428956b67a0454a7f8cbed1de74b3b01e5c33c5378e22740f763'
- '117fc1ca24d98dbe1a60c072cde13be863d429134907797f8e03f654ce679385')
-
-prepare() {
- # Needed for new libsodium
- sed -i 's/libzmq_werror="yes"/libzmq_werror="no"/' $_pkgname-$pkgver/configure
-}
+source=("https://github.com/${_pkgname}/libzmq/releases/download/v$pkgver/${_pkgname}-${pkgver}.tar.gz"
+ "zmq.hpp.$pkgver.tgz::https://github.com/${_pkgname}/cppzmq/archive/v${_cppver}.tar.gz")
+sha256sums=('9d9285db37ae942ed0780c016da87060497877af45094ff9e1a1ca736e3875a2'
+ '9853e0437d834cbed5d3c223bf1d755cadee70e7c964c6e42c4c6783dee5d02c')
build() {
cd "$srcdir/$_pkgname-$pkgver"
./configure prefix=/usr --with-pgm --with-libsodium \
- --with-documentation --enable-static --enable-drafts
+ --with-documentation --enable-static --disable-Werror --enable-drafts
make
}