summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c94dc88e186..2f8f3daf0620 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,21 @@
# Maintainer: redfish <redfish at galactica dot pw>
pkgname='zeronet'
-pkgver=0.6.5
+pkgver=0.7.1
pkgrel=1
arch=('any')
url="https://zeronet.io/"
-depends=('python2'
- 'python2-gevent'
- 'python2-msgpack')
-optdepends=('tor: anonymity')
+depends=('python' 'python-gevent>=1.1.0' 'python-gevent-websocket'
+ 'python-msgpack>=0.4.4' 'python-websocket-client' 'python-rsa'
+ 'python-pysocks' 'python-pyasn1' 'python-pyasn1-modules'
+ 'python-base58' 'python-merkletools'
+ 'python-pyelliptic>=2.0.1'
+ 'python-bencode.py' 'python-coincurve'
+ 'python-bitcoinlib' 'python-maxminddb'
+ 'geoip2-database')
+optdepends=('tor: anonymity'
+ 'namecoin-core: local name resolution')
+checkdepends=('python-pytest' 'python-mock')
license=('GPL2')
pkgdesc="Decentralized websites using Bitcoin crypto and the BitTorrent network."
source=("https://github.com/HelloZeroNet/ZeroNet/archive/v$pkgver.tar.gz"
@@ -33,6 +40,9 @@ package() {
install -D -m644 "$srcdir/$_pkgarchive/LICENSE" "$pkgdir/usr/share/licenses/$_pkgarchive/LICENSE"
}
-sha256sums=('28ca440099323ac307c6ed0afbaf607e4c1c47948917c0c97126a2ec6a293f51'
- 'ea735e82dbb10a2c1fda7abfeb2f38c2429044d8254f9e2396c50cecb6f778f8'
- '8e8df96340cb342b6262ac498292749e01ce5f713b03d5e31384b1f289d9ca62')
+sha256sums=('78a27e1687d8e3699a854b77b516c95b30a8ba667f7ebbef0aabf7ec6ec7272d'
+ '34c349ab5a233afd64e8a9c1d2140c7380fe6c730ed55fb08c6ca4c3a2fa6a89'
+ '398965191fb95f78849d12ea6b8a2c475b702456c541e5971c77d11a47d15827')
+sha256sums=('78a27e1687d8e3699a854b77b516c95b30a8ba667f7ebbef0aabf7ec6ec7272d'
+ '289b4292b1a9346fbefc2bd8c2bb12c2fe7b5bc630dbdfabc778b0a23a16941c'
+ '398965191fb95f78849d12ea6b8a2c475b702456c541e5971c77d11a47d15827')