summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbe14684c3f8..7f210c5e4371 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
pkgname=zerotwo-git
pkgver=0.6.2+beta
-pkgrel=3
+pkgrel=4
pkgdesc='AniList anime tracker written with Electron & Vue.js (git)'
arch=(i686 x86_64)
url=https://www.zerotwo.org
license=(GPL3)
+provides=(zerotwo)
conflicts=(zerotwo zerotwo-bin)
makedepends=(git npm)
source=(git+https://github.com/NicoAiko/zerotwo
@@ -26,7 +27,7 @@ build() {
# Generate them at https://anilist.co/settings/developer
_api_id=
_api_secret=
- if [ -z $_api_id ] || [ -z $_api_secret ] ; then
+ if [ -z $_api_id ] || [ -z $_api_secret ]; then
echo "AniList API client ID and secret must be manually set for ZeroTwo to function properly. Quitting..."
exit
fi
@@ -47,7 +48,7 @@ package() {
cp -a linux-unpacked "$pkgdir"/usr/share/zerotwo
ln -s /usr/share/zerotwo/zerotwo-ui "$pkgdir"/usr/bin/zerotwo
- for i in 16 32 64 128 256 512 1024 ; do
+ for i in 16 32 64 128 256 512 1024; do
install -Dm 644 icons/ZeroTwoAppIcon_$i* "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/zerotwo.png
done
}