summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a708a5544df8..102a7c2a38cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Contributor: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
pkgname=zesarux-git
-pkgver=ZEsarUX.11.0.beta1.r30.g2056b3e
+pkgver=ZEsarUX.11.0.Beta2.r13.g322cf11
_ver=11.0
pkgrel=1
-epoch=2
+epoch=3
pkgdesc="A Zx80/Zx81/Z88, Zx Spectrum 16/48/128/+2/+2A and ZX-Uno emulator with ULAPlus support. Development version."
arch=('i686' 'x86_64')
url="https://github.com/chernandezba/zesarux"
@@ -15,6 +15,7 @@ depends=('libxxf86vm' 'aalib' 'libcaca' 'alsa-lib')
optdepends=('libpulse: for support Pulseaudio'
'openssl: for enable SSL functions'
'sdl: for support sdl video and audio output')
+options=(!debug)
source=('zesarux-code::git+https://github.com/chernandezba/zesarux.git'
zesarux.desktop
zesarux.png)
@@ -31,6 +32,11 @@ pkgver() {
build() {
cd "$srcdir/zesarux-code/src"
+
+ # Working around a gcc bug (?)
+
+ export CFLAGS=-Wno-implicit-function-declaration
+
# disable libcaca for now
./configure --prefix /usr --enable-memptr --enable-visualmem --enable-cpustats --disable-caca --enable-sdl2
sed -i 's/tar -C/#tar -C/g' Makefile