summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cdfc2478f69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Arch-Jason <arch-jason@outlook.com>
+pkgname=zff
+pkgver=5.5.3
+pkgrel=1
+pkgdesc="A simple game"
+arch=(x86_64)
+url="https://github.com/ohzff/Zff"
+license=('MIT')
+depends=('git' 'wget' 'gcc' 'bash')
+makedepends=('gcc' 'git')
+source=("git+$url")
+md5sums=("SKIP")
+
+prepare() {
+ cd Zff
+}
+
+build() {
+ cd Zff
+ g++ zff_main_en.cpp -o zff
+}
+
+package() {
+ cd Zff
+ mkdir -p "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/usr/share/ohzff-zff"
+ install -m775 zff "$pkgdir/usr/bin/zff"
+ cd ../
+ cp -r Zff/* "$pkgdir/usr/share/ohzff-zff"
+}