summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb2ee5100ea8..d9bfcd51157d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,18 +10,22 @@
#
pkgname=zfs-dkms-git
-pkgver=2.2.99.r63.g8e20e0ff39
+pkgver=2.2.99.r344.ga0635ae731
pkgrel=1
epoch=2
-pkgdesc='Kernel modules for the Zettabyte File System.'
+pkgdesc="Kernel modules for the Zettabyte File System."
arch=('any')
-url='https://zfsonlinux.org/'
+url="https://zfsonlinux.org/"
license=('CDDL')
groups=('zfs-git')
+depends=('dkms')
makedepends=('git')
-provides=("ZFS-MODULE=${pkgver}" "SPL-MODULE=${pkgver}" "${pkgname%-git}=${pkgver}" 'spl-dkms')
-conflicts=("${pkgname%-git}" 'spl-dkms')
-replaces=('spl-dkms-git')
+optdepends=("zfs-utils-git=${epoch}:${pkgver}")
+provides=("ZFS-MODULE=${pkgver}" "SPL-MODULE=${pkgver}")
+# ambiguous, provided for backwards compat, pls don't use
+provides+=('zfs')
+provides+=("zfs-dkms=${pkgver}")
+conflicts=('zfs-dkms')
source=("git+https://github.com/openzfs/zfs.git"
"0001-only-build-the-module-in-dkms.conf.patch")
sha256sums=('SKIP'
@@ -61,8 +65,6 @@ build() {
}
package() {
- depends=("zfs-utils-git=${epoch}:${pkgver}" 'dkms')
-
cd zfs
dkmsdir="${pkgdir}/usr/src/zfs-${pkgver}"