summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6563f34690f..a1eb585f844d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ _kernelver="4.18.9.arch1-1"
_extramodules="${_kernelver/.arch/-arch}-ARCH"
pkgver="${_zfsver}_$(echo ${_kernelver} | sed s/-/./g)"
-pkgrel=1
+pkgrel=2
makedepends=("linux-headers=${_kernelver}" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
@@ -47,7 +47,7 @@ package_zfs-linux() {
install=zfs.install
provides=("zfs")
groups=("archzfs-linux")
- conflicts=('zfs-linux-git')
+ conflicts=("zfs-dkms" "zfs-dkms-git" 'zfs-linux-git')
replaces=("zfs-git")
cd "${srcdir}/zfs-${_zfsver}"
make DESTDIR="${pkgdir}" install
@@ -59,7 +59,8 @@ package_zfs-linux() {
package_zfs-linux-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ provides=("zfs-headers")
+ conflicts=("zfs-headers" "zfs-dkms" "zfs-dkms-git")
cd "${srcdir}/zfs-${_zfsver}"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"