summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD74
1 files changed, 74 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..467d7ec43f43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: Francois Menning <f.menning@pm.me>
+# Contributor: Jan Houben <jan@nexttrex.de>
+# Contributor: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
+# ! WARNING !
+#
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-linux-ck packages will only work with the default linux-ck package! To have a single PKGBUILD target many
+# kernels would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+pkgbase="zfs-linux-ck-zen"
+pkgname=("zfs-linux-ck-zen" "zfs-linux-ck-zen-headers")
+_zfsver="2.0.4"
+_kernelver="5.12.3-1"
+_extramodules="${_kernelver/.ck/-ck}-ck-zen"
+
+pkgver="${_zfsver}_$(echo ${_kernelver} | sed s/-/./g)"
+pkgrel=1
+makedepends=("linux-ck-zen-headers=${_kernelver}")
+arch=("x86_64")
+url="https://zfsonlinux.org/"
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${_zfsver}/zfs-${_zfsver}.tar.gz"
+ "linux-5.12-compat.patch")
+sha256sums=("7d1344c5433b91823f02c2e40b33d181fa6faf286bea5591f4b1965f23d45f6c"
+ "9c601804dc473766d85da2198aa3769707e051d3659dc82dd1302edd5e91a8cf")
+license=("CDDL")
+depends=("kmod" "zfs-utils=${_zfsver}" "linux-ck-zen=${_kernelver}")
+prepare() {
+ cd "${srcdir}/zfs-${_zfsver}"
+ patch -Np1 -i ${srcdir}/linux-5.12-compat.patch
+}
+
+build() {
+ cd "${srcdir}/zfs-${_zfsver}"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
+ --datadir=/usr/share --includedir=/usr/include --with-udevdir=/usr/lib/udev \
+ --libexecdir=/usr/lib --with-config=kernel \
+ --with-linux=/usr/lib/modules/${_extramodules}/build \
+ --with-linux-obj=/usr/lib/modules/${_extramodules}/build
+ make
+}
+
+package_zfs-linux-ck-zen() {
+ pkgdesc="Kernel modules for the Zettabyte File System."
+ install=zfs.install
+ provides=("zfs" "spl")
+ groups=("archzfs-linux-ck")
+ conflicts=("zfs-dkms" "zfs-dkms-git" "zfs-dkms-rc" "spl-dkms" "spl-dkms-git" 'zfs-linux-ck-git' 'spl-linux-ck')
+ replaces=("spl-linux-ck")
+ cd "${srcdir}/zfs-${_zfsver}"
+ make DESTDIR="${pkgdir}" INSTALL_MOD_PATH=/usr install
+ # Remove src dir
+ rm -r "${pkgdir}"/usr/src
+}
+
+package_zfs-linux-ck-zen-headers() {
+ pkgdesc="Kernel headers for the Zettabyte File System."
+ provides=("zfs-headers" "spl-headers")
+ conflicts=("zfs-headers" "zfs-dkms" "zfs-dkms-git" "zfs-dkms-rc" "spl-dkms" "spl-dkms-git" "spl-headers")
+ cd "${srcdir}/zfs-${_zfsver}"
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/lib"
+ # Remove reference to ${srcdir}
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/${_extramodules}/Module.symvers
+}