summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91de2457212e..5c9d8e851519 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,29 +17,24 @@
pkgbase="zfs-linux-git"
pkgname=("zfs-linux-git" "zfs-linux-git-headers")
-pkgver=0.7.0.r200.gd4677269f.4.14.3.1
-pkgrel=4
-makedepends=("linux-headers=4.14.3-1" "git" "spl-linux-git-headers")
+pkgver=2017.12.08.r3208.4e9b15696.4.14.5.1
+pkgrel=1
+makedepends=("linux-headers=4.14.5-1" "git" "spl-linux-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=4e9b156960562373e005798575a3fbc6d66e32ff")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-git" "zfs-utils-common-git>=0.7.0.r200.gd4677269f" "linux=4.14.3-1")
-
-pkgver() {
- cd "${srcdir}/zfs"
- echo $(git describe --long | sed 's/^zfs-//;s/\([^-]*-g\)/r\1/;s/-/./g').4.14.3.1
-}
+depends=("kmod" "spl-linux-git" "zfs-utils-common-git=2017.12.08.r3208.4e9b15696" "linux=4.14.5-1")
build() {
cd "${srcdir}/zfs"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.3 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.3-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.14.3-1-ARCH/build
+ --libexecdir=/usr/lib/zfs-0.7.4 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.14.5-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.14.5-1-ARCH/build
make
}
@@ -60,10 +55,10 @@ package_zfs-linux-git() {
package_zfs-linux-git-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.3-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.5-1-ARCH/Module.symvers
}