summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fd5e25495a2..1cd061bcdab0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,15 +18,15 @@
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-pkgver=2017.12.21.r3220.a8b2e3068.4.14.8.b.1
+pkgver=2017.12.22.r3222.823d48bfb.4.14.9.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.14.8.b-1" "git" "spl-linux-hardened-git-headers")
+makedepends=("linux-hardened-headers=4.14.9.a-1" "git" "spl-linux-hardened-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#commit=a8b2e30685c9214ccfd0181977540e080340df4e")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=823d48bfb182137c53b9432498f1f0564eaa8bfc")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2017.12.21.r3220.a8b2e3068" "linux-hardened=4.14.8.b-1")
+depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git=2017.12.22.r3222.823d48bfb" "linux-hardened=4.14.9.a-1")
build() {
cd "${srcdir}/zfs"
@@ -34,8 +34,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.5 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.8-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.14.8-1-hardened/build
+ --with-linux=/usr/lib/modules/4.14.9-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.14.9-1-hardened/build
make
}
@@ -55,10 +55,10 @@ package_zfs-linux-hardened-git() {
package_zfs-linux-hardened-git-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.8-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.9-1-hardened/Module.symvers
}