summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 8 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6019e95cd3f3..ef38af519827 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,15 @@
# Contributor: Jan Houben <jan@nexttrex.de>
# Contributor: Jesus Alvarez <jeezusjr at gmail dot com>
#
-# This PKGBUILD was generated by the archzfs build scripts located at
-#
-# http://github.com/archzfs/archzfs
-#
-# ! WARNING !
-#
-# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
-# case, the archzfs-linux-lts packages will only work with the default linux-lts package! To have a single PKGBUILD target
-# many kernels would make for a cluttered PKGBUILD!
-#
-# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
-# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
-# archzfs github page.
+# WARNING: This package does not build in its current form due to licensing
+# incompatibilities. Some of the linux-rt patches change some of the exported
+# kernel symbols to GPL-only which conflicts with the zfs CDDL license.
#
pkgbase="zfs-linux-rt"
pkgname=("zfs-linux-rt" "zfs-linux-rt-headers")
-_zfsver="2.1.2"
-_kernelver="5.15.5.22.realtime1-1"
-_extramodules="5.15.5.22.realtime1-1-rt"
+_zfsver="2.1.4"
+_kernelver="5.17.1.17.realtime2-3"
+_extramodules="5.17.1.17.realtime2-3-rt"
pkgver="${_zfsver}_$(echo ${_kernelver} | sed s/-/./g)"
pkgrel=1
@@ -28,7 +18,7 @@ makedepends=("linux-rt-headers=${_kernelver}")
arch=("x86_64")
url="https://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${_zfsver}/zfs-${_zfsver}.tar.gz")
-sha256sums=('258cf1d17a1f668a3b99b61eaf14be06c614df42503db0319bef1b9fc4c8b9e7')
+sha256sums=('3b52c0d493f806f638dca87dde809f53861cd318c1ebb0e60daeaa061cf1acf6')
license=("CDDL")
depends=("kmod" "zfs-utils=${_zfsver}" "linux-rt=${_kernelver}")
@@ -50,7 +40,7 @@ package_zfs-linux-rt() {
groups=("archzfs-linux-rt")
conflicts=("zfs-dkms" "zfs-dkms-git" "zfs-dkms-rc" "spl-dkms" "spl-dkms-git")
cd "${srcdir}/zfs-${_zfsver}"
- make DESTDIR="${pkgdir}" INSTALL_MOD_PATH=/usr install
+ make DESTDIR="${pkgdir}" INSTALL_MOD_PATH=${pkgdir}/usr INSTALL_MOD_STRIP=1 install
# Remove src dir
rm -r "${pkgdir}"/usr/src
}