summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54f58a6bf621
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# This file was generated by GoReleaser. DO NOT EDIT.
+# Maintainer: Ben Lavery-Griffiths <ben at lavery-griffiths dot com>
+
+pkgname='zht-bin'
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='The ZSH History Tool'
+url='https://github.com/forquare/zht'
+arch=('aarch64' 'armv6h' 'i686' 'x86_64')
+license=('MIT')
+provides=('zht')
+conflicts=('zht')
+
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/forquare/zht/releases/download/0.2.0/zht_0.2.0_Linux_ARM64.tar.gz")
+sha256sums_aarch64=('9fc1e71118cc80e9088bc44bcda1bd66077afc751d38efc1e36b8494faf67d64')
+
+source_armv6h=("${pkgname}_${pkgver}_armv6h.tar.gz::https://github.com/forquare/zht/releases/download/0.2.0/zht_0.2.0_Linux_ARMv6.tar.gz")
+sha256sums_armv6h=('9162bd5bdd1382dddeedc239a0f803911b2b04d4b248f228d0cc9e2eccc4b893')
+
+source_i686=("${pkgname}_${pkgver}_i686.tar.gz::https://github.com/forquare/zht/releases/download/0.2.0/zht_0.2.0_Linux_32bit.tar.gz")
+sha256sums_i686=('254b80dc28b2749cf662a1380a87e81efd539b236ff665564c17fb062c55fdf6')
+
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/forquare/zht/releases/download/0.2.0/zht_0.2.0_Linux_64bit.tar.gz")
+sha256sums_x86_64=('1734dc6b9aaebd5c095ba2c27a3f628dca4a1fa249419c34bfea8f67a99f7f11')
+
+package() {
+ install -Dm755 "./zht" "${pkgdir}/usr/bin/zht"
+}