summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91aaa4af472f..7fb1fdcc29f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,23 @@
-# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=zoem
-pkgver=11.166
-pkgrel=2
+pkgver=21.341
+pkgrel=1
pkgdesc='Zoem programming language'
arch=(x86_64)
url='https://micans.org/zoem/'
license=(GPL2)
+depends=('readline')
+makedepends=('cimfomfa')
+options=('makeflags')
source=("https://micans.org/zoem/src/$pkgname-${pkgver/./-}.tar.gz")
-sha256sums=('1267a222ae2ee998a91dbe66df19cf998a0e7db45c7e59821049ae6b791f37fe')
+sha256sums=('370efc7f999572888f4e722cbff40efba395a5435f192e734e7ff87810a68768')
+
+prepare() {
+ cd "$pkgname-${pkgver/./-}/src"
+ sed -i '3s/^char/extern char/' "version.h"
+}
build() {
cd "$pkgname-${pkgver/./-}"
@@ -16,7 +25,7 @@ build() {
export CFLAGS="$CFLAGS -march=x86-64 -std=c11 -w"
export CXXFLAGS="$CXXFLAGS -march=x86-64 -std=c++14 -w"
autoreconf -i
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --enable-maintainer-mode
make
}