summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2509d8849e02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Grigorii Horos <horosgrisa@gmail.com>
+
+_git=0a2c31d11c53ea65e503f31e78604551aa26ecd7 # lastest commit 20150806
+pkgname=zpm
+pkgver=20150806
+pkgrel=1
+pkgdesc="ZPM ( Zsh plugin manager ) is an yet another plugin manager for zsh similar to vim-plug"
+arch=('any')
+url="https://github.com/horosgrisa/${pkgname}"
+license=('LGPL3')
+options=('!strip')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${_git}.tar.gz")
+sha256sums=('e7e1da3313a84d57a48986c8498fc45431c0b025fb177ac2726d4c728bda3289')
+
+package() {
+ install -d ${pkgdir}/usr/share/zpm
+ cp -r ${srcdir}/${pkgname}-${_git}/{plugins,zpm.zsh,zshrc-example} ${pkgdir}/usr/share/zpm
+ install -D -m644 ${srcdir}/${pkgname}-${_git}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+} \ No newline at end of file