summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de40905f9b3a..f0c6dfa6227a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alexandros Theodotou <alex@zrythm.org>
pkgname=zrythm
-pkgver=0.4.151
+pkgver=0.5.007
pkgrel=1
pkgdesc="An highly automated, intuitive, Digital Audio Workstation (DAW)"
arch=( 'x86_64' )
@@ -8,23 +8,29 @@ url='https://git.zrythm.org/zrythm/zrythm'
license=( 'GPL3' )
depends=('gtk3' 'lv2' 'lilv' 'libx11' 'jack'
'libsndfile' 'libyaml' 'gettext' 'qt5-base'
- 'libsamplerate' 'alsa-lib' 'ffmpeg' 'portaudio'
+ 'libsamplerate' 'alsa-lib' 'portaudio'
'ladspa' 'fftw')
-makedepends=('python' 'gettext' 'sed' 'libtool')
+makedepends=('python' 'gettext' 'sed'
+ 'meson' 'ninja')
conflicts=( 'zrythm-git' )
source=( "https://git.zrythm.org/zrythm/${pkgname}/-/archive/v$pkgver/${pkgname}-v$pkgver.tar.gz" )
-md5sums=( '5eebcbb84df1ad1d8c79f3fb94e87cec' )
+md5sums=( '0f54a1b6228373841078331dd345f25a' )
rootdir="${pkgname}-v${pkgver}"
build() {
cd ${rootdir}/
- autoreconf -fi
- ./configure --prefix=/usr --with-qt5 --with-ffmpeg
- make
+ mkdir -p build
+ cd build && meson --prefix=/usr .. -Denable_tests=true
+ ninja
+}
+
+check() {
+ cd ${rootdir}/
+ cd build && ninja test
}
package() {
cd ${rootdir}/
- make DESTDIR="${pkgdir}/" install
+ cd build && DESTDIR="${pkgdir}/" ninja install
}