summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9dcb151fee97..86c23bc6f115 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexandros Theodotou <alex@zrythm.org>
_pkgname=zrythm
pkgname=$_pkgname-git
-pkgver=0.4.151.r2.g58e3f445
+pkgver=0.5.007.r2.g6a0eed7b
pkgrel=1
pkgdesc="An highly automated, intuitive, Digital Audio Workstation (DAW)"
arch=( 'x86_64' )
@@ -9,9 +9,10 @@ url='https://git.zrythm.org/zrythm/zrythm'
license=( 'GPL3' )
depends=('gtk3' 'lv2' 'lilv' 'libx11' 'jack'
'libsndfile' 'libyaml' 'gettext' 'qt5-base'
- 'libsamplerate' 'alsa-lib' 'ffmpeg' 'libgtop'
- 'portaudio' 'ladspa' 'fftw')
-makedepends=('python' 'gettext' 'sed' 'git' 'libtool')
+ 'libsamplerate' 'alsa-lib' 'portaudio'
+ 'ladspa' 'fftw')
+makedepends=('python' 'gettext' 'sed'
+ 'meson' 'ninja')
conflicts=( "$_pkgname" )
provides=( "$_pkgname" )
source=("$_pkgname::git+https://git.zrythm.org/zrythm/zrythm.git")
@@ -25,12 +26,17 @@ pkgver () {
build() {
cd "$srcdir/$_pkgname"
- autoreconf -fi
- ./configure --prefix=/usr --with-ffmpeg --with-qt5
- make
+ mkdir -p build
+ cd build && meson --prefix=/usr .. -Denable_tests=true
+ ninja
+}
+
+check() {
+ cd "$srcdir/$_pkgname"
+ cd build && ninja test
}
package() {
cd "$srcdir/$_pkgname"
- make DESTDIR="${pkgdir}/" install
+ cd build && DESTDIR="${pkgdir}/" ninja install
}