summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fe2b95ee86f..fd2f9fe56c03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Sebastian Wiesner <sebastian@swsnr.de>
pkgname=zsa-wally
-pkgver=2.1.0
-pkgrel=13
+pkgver=2.1.1
+pkgrel=1
pkgdesc="Flash your ZSA Keyboard the EZ way."
arch=('i686' 'x86_64')
url="https://github.com/zsa/wally"
@@ -14,14 +14,14 @@ source=(
"modernize-udev-rules.patch"
"desktop-file.patch"
)
-md5sums=('f4a98a0e51d5d0b6d23a95858d230e11'
- 'd444c2b74b3c51c265f91020942075bc'
+md5sums=('7eaa2f3830036028ae50badfdffb1e5e'
+ '08e3b0ae2f4fef743f7b7304fcc20ebd'
'e1800d7066a392864619db15145fe735')
-sha1sums=('deb20d7c9b1a1eb799bb2288540fb7119f1f8ba2'
- '62c1903d3723399d209f0642849d850e91feaef8'
+sha1sums=('765bb9e39dc5589ddd078a51ca743d4ece5c806d'
+ 'c2a11854e3d34d676c3ac6859a35e950bfc6b5a2'
'3e1bd7e97924712381860ae3264b6600f5e9c23c')
-sha512sums=('d84c469f7d43ba86eb5d0d527a17b588ea12e0272897231392e0572cef0a80f806948a225e263806e5cf7b2fc95eb58e02468ecbe8d12f69ec07919eb364e789'
- '923cd4c9795f9828a827e8f5d832ee6f0b74aeb19d948f4e9d8eb7b59d93a570a4bd5e0e0e0b24adfa78644df60425063b37f19ae658e1a3c6200a6c9c126793'
+sha512sums=('2168c92e31053d78ce6914db023cae49781a2d47a97d173602cabca9d19cbbda95c3774b18f6a73de2aa65550d329af1b5458e82a3aff43714e9f29fc1060782'
+ '5c1015f5e480241e71a2dffd3c5d92d2934e7b8ec2fe5b50e0bbe3e94c049bbc67d5cdadb1941de4a99e0033c9ee568141f368ca52d4ab2913afb7bfa67f6141'
'1f967e5ec80760b9a0cf0345d5227caf679398b3b78e0f05ddd5a5c1909039c15a8547aee9174e76beac84395a2b63b31c74396a66bce2193517f494b92216b4')
prepare() {
@@ -31,7 +31,8 @@ prepare() {
patch --strip=1 --input="$srcdir/desktop-file.patch"
export GOPATH="$srcdir/gopath"
- go get -modcacherw -u github.com/wailsapp/wails/cmd/wails@v1.8.0
+ # This needs to be the same version as in mod.go from wally
+ go get -modcacherw github.com/wailsapp/wails/cmd/wails@v1.16.2
}
build() {
@@ -57,7 +58,5 @@ package() {
install -Dm644 -t "$pkgdir/usr/lib/udev/rules.d/" dist/linux64/50-oryx.rules dist/linux64/50-wally.rules
install -Dm644 dist/linux64/wally.desktop "$pkgdir/usr/share/applications/wally.desktop"
install -Dm644 appicon.png "$pkgdir/usr/share/pixmaps/wally.png"
- # This file is only on master; meanwhile use the license from the Debian package copyright file
- install -Dm644 dist/ppa/wally/template/debian/copyright "$pkgdir/usr/share/licenses/$pkgname/copyright"
- #install -Dm644 license.md "$pkgdir/usr/share/licenses/$pkgname/license.md"
+ install -Dm644 license.md "$pkgdir/usr/share/licenses/$pkgname/license.md"
}