summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 16 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 148619e45cdf..22b9348a657f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,28 @@
-# Maintainer: Jiří Prokop <jprokop@synaptiko.cz>
+# Maintainer: Christopher Fair <christopherpfair@comcast.net>
pkgname=zsa-wally
-pkgver=2.0.0
-pkgrel=7
+pkgver=2.1.0
+pkgrel=1
pkgdesc="Wally: Flash your ZSA Keyboard the EZ way."
arch=('i686' 'x86_64')
url="https://github.com/zsa/wally"
license=('MIT')
-depends=('npm' 'gtk3' 'webkit2gtk' 'libusb')
+depends=('gtk3' 'webkit2gtk' 'libusb')
provides=('wally')
-source=("https://github.com/zsa/wally/archive/${pkgver}-linux.tar.gz"
- "50-wally.rules"
+source=("https://github.com/zsa/wally/releases/download/${pkgver}-linux/wally"
+ "https://github.com/zsa/wally/blob/${pkgver}-linux/appicon.png"
+ "https://github.com/zsa/wally/blob/${pkgver}-linux/dist/linux64/50-wally.rules"
+ "https://github.com/zsa/wally/blob/${pkgver}-linux/dist/linux64/wally.desktop"
)
-sha256sums=('9dd7dc0b62e3b8ae15684cb10995a8ff04e285ef0bf1a61069040bd7c5c13683'
- 'SKIP'
+sha256sums=('cdb168899d4e3a81eddfcfa7746d1e4e0dab886ea043644e54339b51f396c087'
+ 'aeb6cb2a6a9db56f19023e3dde605256106c193d51e537f99dbb80b365c62443'
+ '8dda04163592f848276632623aceedb9ccf13264ef620828b340a8cdf05056cb'
+ '179cdd6ec837a9b5a629385bfa111def8b6b2ebc9b5988d3f0d6caed5566b6a5'
)
-build() {
- export GOPATH="$srcdir"/gopath
- export GOBIN="$srcdir"/gopath/bin
- export PATH=$GOBIN:$PATH
- cd "$srcdir/wally-$pkgver-linux"
- go get github.com/wailsapp/wails/cmd/wails
- wails build
-}
-
-
package() {
- install -Dm644 50-wally.rules "$pkgdir"/etc/udev/rules.d/50-wally.rules
- install -Dm755 $srcdir/wally-$pkgver-linux/build/wally "$pkgdir"/usr/bin/wally
- chmod -R uag+rw $srcdir
+ install -Dm644 appicon.png "$pkgdir/usr/share/pixmaps/wally.png"
+ install -Dm755 wally "$pkgdir/usr/bin/wally"
+ install -Dm644 -t "$pkgdir/etc/udev/rules.d" 50-wally.rules
+ install -Dm644 -t "$pkgdir/usr/share/applications" wally.desktop
}