summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa622056ff69..9abf0a2142d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,30 @@
# Maintainer: Jiří Prokop <jprokop@synaptiko.cz>
pkgname=zsa-wally
-pkgver=1.1.1
-pkgrel=2
+pkgver=2.0.0
+pkgrel=1
pkgdesc="Wally: Flash your ZSA Keyboard the EZ way."
arch=('i686' 'x86_64')
url="https://github.com/zsa/wally"
license=('MIT')
depends=('gtk3' 'webkit2gtk' 'libusb')
provides=('wally')
-source=('https://github.com/zsa/wally/releases/download/1.1.1-linux/wally'
- '50-wally.rules'
+source=("https://github.com/zsa/wally/archive/${pkgver}-linux.tar.gz"
+ "50-wally.rules"
)
-sha256sums=('ef3c743bb3d15f6f5b01f6cddd189a4761be12175d63e852651dbb6653e21d0f'
+sha256sums=('9dd7dc0b62e3b8ae15684cb10995a8ff04e285ef0bf1a61069040bd7c5c13683'
'SKIP'
)
+build() {
+ export GOPATH="$srcdir"/gopath
+ cd "$srcdir/wally-$pkgver-linux"
+ go get -u github.com/wailsapp/wails/cmd/wails
+ wails build
+}
+
+
package() {
install -Dm644 50-wally.rules "$pkgdir"/etc/udev/rules.d/50-wally.rules
- install -Dm755 wally "$pkgdir"/usr/bin/wally
+ install -Dm755 $srcdir/wally-$pkgver-linux/build/wally "$pkgdir"/usr/bin/wally
}