summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 27 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 544d59b45c38..56515cdbc06e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,34 @@
-# Maintainer: Andrii Burkivskyi <buryk212@gmail.com>
-_gitname='zsh-extract'
-pkgname="${_gitname}-git"
-pkgver=r2.85ee9a2
+# Maintainer: espritlibre <email@address.invalid>"
+_pkgname=zsh-extract
+pkgname=zsh-extract-git
+pkgver=r7156.06753e814
pkgrel=1
-pkgdesc="This plugin defines a function called extract that extracts the archive file you pass it, and it supports a wide variety of archive filetypes."
-arch=('any')
-url="https://github.com/le0me55i/zsh-extract"
-license=(custom:MIT)
-depends=('zsh')
-makedepends=('git')
-provides=('zsh-extract')
-conflicts=('zsh-extract')
-source=("${_gitname}::${url//https/git}")
-install=zsh-extract-git.install
-sha256sum=('SKIP')
+pkgdesc="This plugin defines a function called "extract", it extracts the archive file you pass to it and it supports a wide variety of archive filetypes."
+arch=(any)
+url="https://github.com/ohmyzsh/ohmyzsh/tree/master/plugins/extract"
+license=('unknown')
+depends=("zsh")
+makedepends=("git")
+install="${pkgname}.install"
+source=(git+https://github.com/ohmyzsh/ohmyzsh.git)
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_gitname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${srcdir}/ohmyzsh/plugins/extract/"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "${srcdir}/${_gitname}"
-
- install -Dm644 extract.plugin.zsh "${pkgdir}/usr/share/zsh/plugins/${_gitname}/extract.plugin.zsh"
- install -Dm644 _extract "${pkgdir}/usr/share/zsh/site-functions/_extract"
- install -Dm644 README.md "${pkgdir}/usr/share/doc/${_gitname}/README.md"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+ install -Dm644 "${srcdir}/ohmyzsh/plugins/extract/_extract" \
+ "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+ install -Dm644 "${srcdir}/ohmyzsh/plugins/extract/extract.plugin.zsh" \
+ "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
+ install -Dm644 "${srcdir}/ohmyzsh/plugins/extract/README.md" \
+ "${pkgdir}/usr/share/zsh/plugins/${_pkgname}"
}
+