summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 26 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b7a0bc77fd3..777e7f5bbb09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,22 @@
_pkgname=powerlevel9k
pkgname=zsh-theme-${_pkgname}-git
pkgver=v0.3.1.r10.g2630526
-pkgrel=2
+pkgrel=3
pkgdesc='Powerlevel9k theme for zsh'
arch=('any')
url='https://github.com/bhilburn/powerlevel9k'
license=('custom')
depends=('zsh')
-optdepends=('oh-my-zsh-git: oh-my-zsh integration'
- 'prezto-git: Prezto integration'
- 'antigen-git: Antigen integration'
- 'zpm: ZPM integration'
- 'zsh-zim-git: Zim integration')
+optdepends=('powerline-fonts: patched fonts for powerline'
+ 'oh-my-zsh-git: oh-my-zsh integration'
+ 'prezto-git: Prezto integration'
+ 'antigen-git: Antigen integration'
+ 'zpm: ZPM integration'
+ 'zsh-zim-git: Zim integration'
+ 'awesome-terminal-fonts: icon package'
+ 'acpi: battery monitoring'
+ 'git: status of repository'
+ 'mercurial: status of repository')
source=("${_pkgname}::git+https://github.com/bhilburn/${_pkgname}.git")
sha256sums=('SKIP')
makedepends=('git')
@@ -24,27 +29,27 @@ install="zsh-theme-${_pkgname}.install"
pkgver()
{
- cd "${srcdir}/${_pkgname}"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package()
{
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
- # No license
- # Install Readme as License in case in the future some type of license is added
- install -D -m644 README.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # No license
+ # Install Readme as License in case in the future some type of license is added
+ install -D -m644 README.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # Install Documentation
- install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ # Install Documentation
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
- # Install the theme
- install -D -m644 powerlevel9k.zsh-theme "${pkgdir}/usr/share/zsh-theme-${_pkgname}/${_pkgname}.zsh-theme"
+ # Install the theme
+ install -D -m644 powerlevel9k.zsh-theme "${pkgdir}/usr/share/zsh-theme-${_pkgname}/${_pkgname}.zsh-theme"
- # Install the utilities
- for FILE in functions/*.zsh; do
- install -D -m644 "${FILE}" "${pkgdir}/usr/share/zsh-theme-${_pkgname}/functions/$(basename ${FILE})"
- done
+ # Install the utilities
+ for FILE in functions/*.zsh; do
+ install -D -m644 "${FILE}" "${pkgdir}/usr/share/zsh-theme-${_pkgname}/functions/$(basename ${FILE})"
+ done
}