summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 22 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e72f0e0486df..01348e37afe6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,42 @@
# Maintainer: Salan54 <salan at fremenil dot com>
# Created: 2013-03-17
+# Contributor: egrupled
+_gitname=zuluCrypt
+_build=build
pkgname=zulucrypt
pkgver=5.5.0
-pkgrel=1
-_altpkgname=zuluCrypt
+pkgrel=2
pkgdesc="A cli and gui frontend to cryptsetup"
-url="http://mhogomchungu.github.io/${_altpkgname}"
+url="https://github.com/mhogomchungu/$_gitname/"
arch=('x86_64' 'i686')
license=('GPL')
depends=('cryptsetup' 'qt5-base' 'libpwquality' 'libsecret' 'libxkbcommon-x11' )
optdepends=('kwalletmanager: retrieve volume keys from kde kwallet')
conflicts=('zulucrypt-git')
-makedepends=('cmake')
-source=("https://github.com/mhogomchungu/zuluCrypt/releases/download/${pkgver}/${_altpkgname}-${pkgver}.tar.xz")
-md5sums=('8d8fbaf3852ab8e13dfd21a7901a4634')
-sha256sums=('d1d4ebd2c58e3bc68f53976adefe26632da11425fdd3bf3e1413cf4b6975e52b')
+makedepends=('cmake' 'git')
+source=("git+https://github.com/mhogomchungu/$_gitname.git#tag=$pkgver")
+sha256sums=('SKIP')
build() {
- cd "${srcdir}/${_altpkgname}-${pkgver}"
- mkdir -p build
- cd build
+ cd "$_gitname"
+ msg "Making Build directory... $_build"
+ if [[ -d "$_build" ]]; then
+ rm -Rf "$_build"
+ fi
+ mkdir -p "$_build"
+ cd "$_build"
cmake -DCMAKE_INSTALL_PREFIX=/usr/ -DLIB_SUFFIX=lib -DNOGUI=false -DQT5=true -DHOMEMOUNTPREFIX=false -DCMAKE_BUILD_TYPE=release . ..
make
}
package() {
- echo "changelog updated"
- cp "${srcdir}/${_altpkgname}-${pkgver}"/changelog ../${pkgname}.changelog
- cd "${srcdir}/${_altpkgname}-${pkgver}/build"
+ msg "changelog updated"
+ cd "$_gitname"
+ cp changelog ../../"$pkgname.changelog"
+ cd "$_build"
make DESTDIR="$pkgdir" install
- mkdir -p ${pkgdir}/etc/modules-load.d
- echo 'loop' > "${pkgdir}/etc/modules-load.d/${pkgname}.conf"
+ mkdir -p "$pkgdir/etc/modules-load.d"
+ echo 'loop' > "$pkgdir/etc/modules-load.d/$pkgname.conf"
}
+