summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22e9cf18b8ef..3d0cee1bca5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hong Shick Pak <hong@hspak.com>
pkgname=zur-git
-pkgver=0.5
+pkgver=0.5.0+3+g49035b5
pkgrel=1
pkgdesc="An AUR helper written in Zig"
arch=("x86_64")
@@ -14,6 +14,11 @@ conflicts=("$pkgname")
source=("git+https://github.com/hspak/zur")
sha256sums=("SKIP")
+pkgver() {
+ cd "$(echo $pkgname | cut -d'-' -f1)"
+ git describe --tags | sed 's/-/+/g'
+}
+
build() {
cd "$(echo $pkgname | cut -d'-' -f1)"
zig build -Dversion="${pkgver}" -Drelease-safe=true