summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f34eb817b06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ZVVUbuntu
+_pkgname=zvvonlinetv
+pkgtest=test
+pkgname=${_pkgname}-$pkgtest
+pkgver=5.2
+pkgrel=1
+pkgdesc="TV | IPTV | youtube player(testing)"
+arch=('i386' 'x86_64')
+url="https://zvvubuntu.blogspot.com"
+license=('custom')
+depends=('pyqt5-common' 'python-pyqt5' 'mpv' 'qt5-multimedia' 'ffmpeg' 'youtube-dl')
+conflicts=('zvvonlinetv')
+source=("${pkgname}_${pkgver}.deb::https://docs.google.com/uc?id=17lWM4Kmg-xS4I31ygl16tKo3Y1TdcSwg")
+md5sums=('5a543ce9294aa6d2c3b77450b573a4e4')
+
+package() {
+ cd "${srcdir}"
+ bsdtar -xf data.tar.xz -C "$pkgdir"
+ chmod -R 755 "${pkgdir}"/usr
+ chmod -R 775 "${pkgdir}"/usr/share/${_pkgname}
+ chmod -R 775 "${pkgdir}"/usr/share/${_pkgname}/modules/
+
+ ######################################################
+ #install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+ #install -Dm755 $_pkgname.desktop $pkgdir/usr/share/applications/$_pkgname.desktop
+}