summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 5 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1b67090c07e..838454b7d23f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,32 @@
# Maintainer: Thibaut PĂ©rami <thibaut.perami@cl.cam.ac.uk>
pkgname=zydis
-pkgver=3.2.1
+pkgver=4.0.0
pkgrel=1
pkgdesc="The ultimate, open-source X86 & X86-64 decoder/disassembler library."
arch=('x86_64')
url="https://zydis.re"
license=('MIT')
-depends=('gcc-libs')
+depends=('gcc-libs' 'zycore-c')
provides=('libZydis.so')
makedepends=('cmake')
-
-# The released version of ZyCore is not recent enough to compile the released version of ZyDis.
-# The hackish workaround is to download the target commit of version 3.2.1 for ZyCore.
-# This will need to be updated when ZyCore gets officially updated.
-source=("https://github.com/zyantific/zydis/archive/v${pkgver}.tar.gz" "https://github.com/zyantific/zycore-c/archive/6c93d9a38e62d4db82f99bf99159e1ee78341e36.zip")
-sha256sums=('349a2d27270e54499b427051dd45f7b6064811b615588414b096cdeeaeb730ad' '8876347e44f4cfdd49b0ce13d150b0715b9cf326d85627f444a4313f4c58be41')
-zycore=zycore-c-6c93d9a38e62d4db82f99bf99159e1ee78341e36
+source=("https://github.com/zyantific/zydis/archive/v${pkgver}.tar.gz")
+sha256sums=('14e991fd97b021e15c77a4726a0ae8a4196d6521ab505acb5c51fc2f9be9530a')
prepare() {
cd "${pkgname}-${pkgver}"
}
build() {
- cd ${zycore}
- cmake -B build -Wno-dev\
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DZYCORE_BUILD_SHARED_LIB=ON
- cmake --build build
- cd ..
-
cd "${pkgname}-${pkgver}"
cmake -B build -Wno-dev\
-DCMAKE_INSTALL_PREFIX=/usr \
-DZYDIS_BUILD_SHARED_LIB=ON \
- -DZYDIS_ZYCORE_PATH=../${zycore} #HACK
+ -DZYAN_SYSTEM_ZYCORE=true
cmake --build build
}
package() {
- cd ${zycore}
- DESTDIR="${pkgdir}" cmake --install build
- cd ..
cd "${pkgname}-${pkgver}"
DESTDIR="${pkgdir}" cmake --install build
install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE