aboutsummarylogtreecommitdiffstats
path: root/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'README.md')
-rw-r--r--README.md50
1 files changed, 35 insertions, 15 deletions
diff --git a/README.md b/README.md
index 3bebe309b412..dcc91d88bef7 100644
--- a/README.md
+++ b/README.md
@@ -2,24 +2,44 @@
A build of keepalived for openrc deployment - nothing fancy, nothing special.
-### Get
-
-NOTE: we recommend cloning into the ~/.aur/ directory - its not necessary but documentation assumes this location.
-
-NOTE: if you are running this as root you will need to preface all commands with `su user -c "command"`
-
-- get PKGBUILD: `cd ~/.aur && git clone https://gitlab.com/drad/keepalived.git`
-
-### Build
-
-Build with: `cd ~/.aur/keepalived && makepkg -src`
-
### Install
-Install with: `cd ~/.aur/keepalived && sudo pacman -U keepalived{version}.pkg.tar.zst`
+Most installations of this package will likely be on a server (which likely is not using or have a user account). If this is the case you can install as nobody user as follows:
+
+1. install needed dependencies:
+```
+pacman -S gcc openssl libnl net-snmp git
+```
+2. create a build directory and set it up to be owned by the nobody user
+```
+mkdir ~/.aur
+chgrp nobody ~/.aur
+chmod g+ws ~/.aur
+setfacl -m u::rwx,g::rwx ~/.aur
+setfacl -d --set u::rwx,g::rwx,o::- ~/.aur
+```
+3. Now you can clone and build:
+```
+git clone https://gitlab.com/drad/keepalived.git \
+ && cd keepalived \
+ && sudo -u nobody makepkg -c \
+ && ls -lh keepalived*.zst
+```
+4. Finally install:
+```
+pacman -U keepalived-openrc-{version-arch}.pkg.tar.zst
+```
+
+Optionally, you can installed the usual AUR way:
+
+```
+git clone https://gitlab.com/drad/keepalived.git
+cd keepalived
+makepkg -sirc
+```
-### Remove
-Remove with: `sudo pacman -R keepalived`
+### Remove
+Remove with: `pacman -R keepalived-openrc`