summarylogtreecommitdiffstats
path: root/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'README.md')
-rw-r--r--README.md46
1 files changed, 33 insertions, 13 deletions
diff --git a/README.md b/README.md
index ccf8e5064584..0b7454269e9a 100644
--- a/README.md
+++ b/README.md
@@ -17,8 +17,8 @@ commit on the `master` branch.
# Package Installation
Using your favorite [AUR
-helper](https://wiki.archlinux.org/index.php/AUR_helpers), install the [lf AUR
-package](https://aur.archlinux.org/packages/lf/) like this:
+helper](https://wiki.archlinux.org/index.php/AUR_helpers), install the [lf
+AUR package](https://aur.archlinux.org/packages/lf/) like this:
```bash
$ aura -A lf
@@ -28,23 +28,33 @@ $ aura -A lf
This section is mostly notes on how this package is maintained.
-### Write Access to the AUR
+## Initial Setup
+
+Whenever setting up the environment to maintain this package, these manual steps
+must be done once.
+
+### 1. Write Access to the AUR
Have a look on the
[wiki](https://wiki.archlinux.org/index.php/Arch_User_Repository#Authentication)
if you don't already have write access to the AUR.
-### Git Mirror
+### 2. Git Mirror
The `github.com/dmarcoux/lf` repository is a mirror of the
-`aur.archlinux.org/lf` repository. Set it up by running the following commands:
+`aur.archlinux.org/lf` repository. Set it up by running the following
+commands:
```bash
$ git clone git+ssh://aur@aur.archlinux.org/lf.git
$ git remote set-url origin --add git@github.com:dmarcoux/lf.git
```
-### Generate the .SRCINFO file
+## Routine Update
+
+Whenever updating this package, these steps must always be done.
+
+### 1. Generate the .SRCINFO file
The tool `mksrcinfo` provided by the [AUR package
`pkgbuild-introspection-git`](https://aur.archlinux.org/packages/pkgbuild-introspection-git)
@@ -55,22 +65,32 @@ repository's root directory to use it:
$ mksrcinfo
```
-### Generate the sha256sums in the PKGBUILD file
+### 2. Generate the checksums in the PKGBUILD file
The script `updpkgsums` (which comes with `pacman`'s version 4.1 or greater) is
-a simple way to generate the sha256sums in the `PKGBUILD` file. It is as simple
+a simple way to generate the checksums in the `PKGBUILD` file. It is as simple
as running the script in the repository's root directory:
```bash
$ updpkgsums
```
-### Automation
+### 3. Validate the PKGBUILD file
+
+The script `makepkg` (which comes with `pacman`) is the usual way to validate a
+`PKGBUILD` file. With a valid `PKGBUILD` file, it will create a package; with a
+nonvalid `PKGBUILD` file, it will raise an error. Simply run the command in the
+repository's root directory to use it:
+
+```bash
+$ makepkg
+```
+
+## Automation
-For the steps `Generate the .SRCINFO file` and `Generate the sha256sums in the
-PKGBUILD file`, I prefer to use a git pre-commit hook
-([pre-commit.sh](pre-commit.sh)) to do this automatically. Set it up by running
-the following command in the repository's root directory:
+All steps in the `Routine Update` section can be automated. To do so, I use a
+git pre-commit hook ([pre-commit.sh](pre-commit.sh)). Set it up by running the
+following command in the repository's root directory:
```bash
$ ln -s ../../pre-commit.sh .git/hooks/pre-commit