aboutsummarylogtreecommitdiffstats
path: root/README
diff options
context:
space:
mode:
Diffstat (limited to 'README')
-rw-r--r--README42
1 files changed, 16 insertions, 26 deletions
diff --git a/README b/README
index b93aa0cd7ed9..7ea109b8ad0a 100644
--- a/README
+++ b/README
@@ -1,31 +1,21 @@
-Linode (http://www.linode.com) is a VPS host with very neat,
-very scriptable server-managing software, which supports
-Arch Linux servers and custom kernels. This project maintains
-the PKGBUILD for an Arch package (installable with pacman)
-containing a kernel that is super-optimized for running on a
-Linode instance, and also the grub menu to boot from it.
+Linode (http://www.linode.com) is a VPS host which supports Arch Linux servers
+and custom kernels. This project gives you an Arch kernel for your Linode.
-Optimizations include compiling for Linode's exact cpu type and
-stripping out all code for hardware that does not exist on Linode,
-i.e. almost everything but the virtual xen block devices, NICs and
-console. I also removed almost all filesystem support as 99% of
-you will just be using their ext3 image and the other 1% will want
-to tweak things anyway.
+linux-linode is designed to closely track Arch kernel development while being as
+resource friendly as possible. Compiles specifically for Linode's CPUs and
+removes unneeded hardware support (i.e. almost everything besides xen block dev,
+NICs & console). Also defaults to removing all filesystems but ext3 and
+compiling in many things that are usually modules (fuse, dm-crypt for example)
+but you can of course nconfig whatever you want. :)
-To build this package on any arch linux machine, just do this:
+Includes a grub boot menu where Linode expects to find it. You do NOT need grub,
+grub2, grub-legacy or any other. grub-legacy is a conflict because of menu.lst.
-* git clone git@github.com:twomen/linux-linode.git ~/linux-linode
-* cd ~/linux-linode
-* makepkg -c
+This is a 64-bit kernel, so make sure you're using their 64-bit Arch image!
-This will give you a file like: linux-linode-3.0.1-1-x86_64.pkg.tar.xz
+Steps to use:
-In order to use this super-optimized kernel on your linode, just do this:
-
-* Make sure you have the 64-bit Arch image (2010-05 at time of writing)
-* pacman -Syu (just to make sure, the image is really old...)
-* Upload pkg file to server
-* sudo pacman -U /path/to/linux-linode-*.pkg.tar.xz
-* set your linode kernel to pv-grub-64
-* reboot
-* tell me about any bugs that were my fault :D
+ 1) pacman -Syu
+ 2) pacman -U /path/to/linux-linode-*-x86_64.pkg.tar.xz
+ 3) reboot your Linode with "kernel" set to: pv-grub-x86_64
+ 4) report bugs ;)