aboutsummarylogtreecommitdiffstats
path: root/UPDATING
diff options
context:
space:
mode:
Diffstat (limited to 'UPDATING')
-rw-r--r--UPDATING23
1 files changed, 10 insertions, 13 deletions
diff --git a/UPDATING b/UPDATING
index 0eae9e20788c..7eea80a33492 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,20 +5,16 @@
# Don't actually run this as a shell script - it's part pseudocode
exit
-# Check https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/linux
-# Bump pkgver, pkgrel
-# Sync any new PKGBUILD logic, important patches, configs or other changes
-
# Cleans things up
makepkg -oecd
-# uncomment "return 1"
-sed -i 's/^[#]*\s*\(return\s*1\)$/\1/ig' PKGBUILD
-
-# sources are ready
-makepkg -cd
+# Check https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/linux
+# Bump pkgver, pkgrel
+# Sync any new PKGBUILD logic, important patches, configs or other changes
+# update hashes
-# will probably fail for hashes, reset hashes & redo
+# prepare sources
+makepkg -o
# may prompt for oldconfig
@@ -34,6 +30,7 @@ diff ../../config.x86_64 .config
cd ../..
cp src/linux-${pkgver}/.config config.x86_64
-# update md5s
-# re-comment "return 1"
-sed -i 's/^[#]*\s*\(return\s*1\)$/# \1/ig' PKGBUILD
+# update md5s + git
+
+# finally:
+makepkg -c