summarylogtreecommitdiffstats
path: root/add_install_taget.patch
diff options
context:
space:
mode:
Diffstat (limited to 'add_install_taget.patch')
-rw-r--r--add_install_taget.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/add_install_taget.patch b/add_install_taget.patch
new file mode 100644
index 000000000000..a9b55eb44762
--- /dev/null
+++ b/add_install_taget.patch
@@ -0,0 +1,23 @@
+Description: Add install target to Makefile
+Forwarded: no
+Origin: no
+Bug-Debian: no
+Author: Nobuhiro Iwamatsu <iwamatsu@debian.org>
+
+--- tinywm-1.3.orig/Makefile
++++ tinywm-1.3/Makefile
+@@ -1,9 +1,14 @@
++BINDIR?=/usr/bin
+ PREFIX?=/usr/X11R6
+ CFLAGS?=-Os -pedantic -Wall
+
+ all:
+ $(CC) $(CFLAGS) -I$(PREFIX)/include -L$(PREFIX)/lib -lX11 -o tinywm tinywm.c
+
++install:
++ install -d ${DESTDIR}${BINDIR}
++ install -m 755 tinywm ${DESTDIR}${BINDIR}
++
+ clean:
+ rm -f tinywm
+