summarylogtreecommitdiffstats
path: root/arch-linux.patch
diff options
context:
space:
mode:
Diffstat (limited to 'arch-linux.patch')
-rw-r--r--arch-linux.patch33
1 files changed, 31 insertions, 2 deletions
diff --git a/arch-linux.patch b/arch-linux.patch
index f28d7a8a083c..9d279c0c4c0c 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -86,15 +86,44 @@ index 4444a9a2..b9c2640d 100644
LOG_PLATFORM("Debian")
elseif(OSQUERY_BUILD_PLATFORM STREQUAL "ubuntu")
diff --git a/osquery/tables/CMakeLists.txt b/osquery/tables/CMakeLists.txt
-index 99477c69..d07730e2 100644
+index 8efb6202..7f9d64aa 100644
--- a/osquery/tables/CMakeLists.txt
+++ b/osquery/tables/CMakeLists.txt
-@@ -67,7 +67,7 @@ if(LINUX)
+@@ -66,8 +66,10 @@ endif()
+ if(LINUX)
set(TABLE_PLATFORM "linux")
++ include_directories("/usr/include/libxml2")
++
ADD_OSQUERY_LINK_ADDITIONAL("libresolv.so")
- ADD_OSQUERY_LINK_ADDITIONAL("cryptsetup devmapper lvm2app lvm-internal daemonclient")
+ ADD_OSQUERY_LINK_ADDITIONAL("cryptsetup devmapper lvm2app")
ADD_OSQUERY_LINK_ADDITIONAL("gcrypt gpg-error")
ADD_OSQUERY_LINK_ADDITIONAL("blkid")
ADD_OSQUERY_LINK_ADDITIONAL("ip4tc")
+diff --git a/osquery/tables/system/linux/tests/md_tables_tests.cpp b/osquery/tables/system/linux/tests/md_tables_tests.cpp
+index bfe71092..2415ae1f 100644
+--- a/osquery/tables/system/linux/tests/md_tables_tests.cpp
++++ b/osquery/tables/system/linux/tests/md_tables_tests.cpp
+@@ -72,7 +72,7 @@ void GetDrivesForArrayTestHarness(std::string arrayName,
+ EXPECT_CALL(md, getArrayInfo(arrayDevPath, _))
+ .WillOnce(DoAll(SetArgReferee<1>(arrayInfo), Return(true)));
+
+- Sequence::Sequence s1;
++ Sequence s1;
+ for (int i = 0; i < MD_SB_DISKS; i++) {
+ mdu_disk_info_t diskInfo;
+ diskInfo.number = i;
+diff --git a/osquery/devtools/shell.cpp b/osquery/devtools/shell.cpp
+index 84507f66..7811b9c8 100644
+--- a/osquery/devtools/shell.cpp
++++ b/osquery/devtools/shell.cpp
+@@ -1185,7 +1185,7 @@ inline void meta_show(struct callback_data* p) {
+
+ {
+ fprintf(p->out, "\nNon-default flags/options:\n");
+- auto results = osquery::SQL::SQL(
++ auto results = osquery::SQL(
+ "select * from osquery_flags where default_value <> value");
+ for (const auto& flag : results.rows()) {
+ fprintf(p->out,