summarylogtreecommitdiffstats
path: root/arch-linux.patch
diff options
context:
space:
mode:
Diffstat (limited to 'arch-linux.patch')
-rw-r--r--arch-linux.patch22
1 files changed, 0 insertions, 22 deletions
diff --git a/arch-linux.patch b/arch-linux.patch
index c226b0477930..10cc8dd26ca9 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -59,28 +59,6 @@ index a367f913..c522d558 100644
-using RecursiveLock = std::lock_guard<std::recursive_mutex>;
+using RecursiveLock = MUTEX_IMPL::lock_guard<MUTEX_IMPL::recursive_mutex>;
}
-diff --git a/osquery/CMakeLists.txt b/osquery/CMakeLists.txt
-index db05af9c..0b5c2291 100644
---- a/osquery/CMakeLists.txt
-+++ b/osquery/CMakeLists.txt
-@@ -70,12 +70,13 @@ endif()
-
- if(APPLE OR LINUX)
- ADD_OSQUERY_LINK_CORE("libdl")
-- ADD_OSQUERY_LINK_CORE("boost_system-mt")
-- ADD_OSQUERY_LINK_CORE("boost_filesystem-mt")
-- ADD_OSQUERY_LINK_CORE("boost_context-mt")
-+ ADD_OSQUERY_LINK_CORE("boost_system")
-+ ADD_OSQUERY_LINK_CORE("boost_filesystem")
-+ ADD_OSQUERY_LINK_CORE("boost_thread")
-+ ADD_OSQUERY_LINK_CORE("boost_context")
-
- ADD_OSQUERY_LINK_ADDITIONAL("rocksdb_lite")
-- ADD_OSQUERY_LINK_ADDITIONAL("boost_regex-mt")
-+ ADD_OSQUERY_LINK_ADDITIONAL("boost_regex")
- elseif(FREEBSD)
- ADD_OSQUERY_LINK_CORE("icuuc")
- ADD_OSQUERY_LINK_CORE("boost_system")
diff --git a/Makefile b/Makefile
index 2e2bd13c..c5ae915a 100644
--- a/Makefile