summarylogtreecommitdiffstats
path: root/be0d3e699401f8230fa88c28c52d73c57f13f327.patch
diff options
context:
space:
mode:
Diffstat (limited to 'be0d3e699401f8230fa88c28c52d73c57f13f327.patch')
-rw-r--r--be0d3e699401f8230fa88c28c52d73c57f13f327.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/be0d3e699401f8230fa88c28c52d73c57f13f327.patch b/be0d3e699401f8230fa88c28c52d73c57f13f327.patch
new file mode 100644
index 000000000000..375a06dbdc68
--- /dev/null
+++ b/be0d3e699401f8230fa88c28c52d73c57f13f327.patch
@@ -0,0 +1,34 @@
+From be0d3e699401f8230fa88c28c52d73c57f13f327 Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Sat, 11 May 2019 10:17:36 +0200
+Subject: [PATCH] meson: define SIZEOF_LONG and use -Wundef
+
+meson builds defaulted to SIZEOF_LONG=0 in various places
+---
+ meson.build | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/meson.build b/meson.build
+index 1a11587..3a1a4c2 100644
+--- a/meson.build
++++ b/meson.build
+@@ -36,6 +36,7 @@ add_project_arguments(
+ '-Wdeclaration-after-statement',
+ '-fno-strict-aliasing',
+ '-fvisibility=hidden',
++ '-Wundef',
+ ]),
+ language : ['c']
+ )
+@@ -445,6 +446,8 @@ if host_machine.endian() == 'big'
+ config.set('WORDS_BIGENDIAN', 1)
+ endif
+
++config.set('SIZEOF_LONG', cc.sizeof('long'))
++
+ # Required to make pixman-private.h
+ config.set('PACKAGE', 'foo')
+
+--
+2.24.1
+