summarylogtreecommitdiffstats
path: root/boost-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'boost-fix.patch')
-rw-r--r--boost-fix.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/boost-fix.patch b/boost-fix.patch
new file mode 100644
index 000000000000..985ad85dc7e5
--- /dev/null
+++ b/boost-fix.patch
@@ -0,0 +1,15 @@
+--- CMakeLists.txt.orig 2019-10-12 00:51:32.023316775 -0400
++++ CMakeLists.txt 2019-10-12 00:51:45.049983337 -0400
+@@ -4,11 +4,7 @@
+ find_package(catkin REQUIRED sensor_msgs rosconsole roscpp roscpp_serialization)
+
+ find_package(PythonLibs REQUIRED)
+-if(PYTHONLIBS_VERSION_STRING VERSION_LESS 3)
+- find_package(Boost REQUIRED COMPONENTS filesystem python)
+-else()
+- find_package(Boost REQUIRED COMPONENTS filesystem python3)
+-endif()
++find_package(Boost REQUIRED COMPONENTS filesystem python)
+ include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
+
+ catkin_python_setup()