summarylogtreecommitdiffstats
path: root/build_info.patch
diff options
context:
space:
mode:
Diffstat (limited to 'build_info.patch')
-rw-r--r--build_info.patch11
1 files changed, 5 insertions, 6 deletions
diff --git a/build_info.patch b/build_info.patch
index 4e025e02067c..b0b8aacec891 100644
--- a/build_info.patch
+++ b/build_info.patch
@@ -1,19 +1,18 @@
diff --git a/Makefile b/Makefile
-index 290fd85..69490ea 100644
+index 476cbef..292355f 100644
--- a/Makefile
+++ b/Makefile
-@@ -32,8 +32,9 @@ SUPPORTED_PLATFORMS := linux-$(GOARCH) darwin-$(GOARCH) windows-$(GOARCH).exe
+@@ -32,7 +32,8 @@ SUPPORTED_PLATFORMS := linux-$(GOARCH) darwin-$(GOARCH) windows-$(GOARCH).exe
BUILD_PACKAGE = $(REPOPATH)/cmd/skaffold
VERSION_PACKAGE = $(REPOPATH)/pkg/skaffold/version
-COMMIT = $(shell git rev-parse HEAD)
+COMMIT ?= $(shell git rev-parse HEAD)
- VERSION ?= $(shell git describe --always --tags --dirty)
+TREE_STATE ?= $(if $(shell git status --porcelain),dirty,clean)
- GO_GCFLAGS := "all=-trimpath=${PWD}"
- GO_ASMFLAGS := "all=-trimpath=${PWD}"
-@@ -43,7 +44,7 @@ GO_LDFLAGS += -extldflags \"${LDFLAGS}\"
+ ifeq "$(strip $(VERSION))" ""
+ override VERSION = $(shell git describe --always --tags --dirty)
+@@ -46,7 +47,7 @@ GO_LDFLAGS += -extldflags \"${LDFLAGS}\"
GO_LDFLAGS += -X $(VERSION_PACKAGE).version=$(VERSION)
GO_LDFLAGS += -X $(VERSION_PACKAGE).buildDate=$(shell date +'%Y-%m-%dT%H:%M:%SZ')
GO_LDFLAGS += -X $(VERSION_PACKAGE).gitCommit=$(COMMIT)