summarylogtreecommitdiffstats
path: root/build_info.patch
diff options
context:
space:
mode:
Diffstat (limited to 'build_info.patch')
-rw-r--r--build_info.patch7
1 files changed, 3 insertions, 4 deletions
diff --git a/build_info.patch b/build_info.patch
index 64e1a735939a..4e025e02067c 100644
--- a/build_info.patch
+++ b/build_info.patch
@@ -1,20 +1,19 @@
diff --git a/Makefile b/Makefile
-index 68bc2ef..e2918d0 100644
+index 290fd85..69490ea 100644
--- a/Makefile
+++ b/Makefile
-@@ -32,9 +32,10 @@ SUPPORTED_PLATFORMS := linux-$(GOARCH) darwin-$(GOARCH) windows-$(GOARCH).exe
+@@ -32,8 +32,9 @@ SUPPORTED_PLATFORMS := linux-$(GOARCH) darwin-$(GOARCH) windows-$(GOARCH).exe
BUILD_PACKAGE = $(REPOPATH)/cmd/skaffold
VERSION_PACKAGE = $(REPOPATH)/pkg/skaffold/version
-COMMIT = $(shell git rev-parse HEAD)
+COMMIT ?= $(shell git rev-parse HEAD)
- BASE_URL ?= https://skaffold.dev
VERSION ?= $(shell git describe --always --tags --dirty)
+TREE_STATE ?= $(if $(shell git status --porcelain),dirty,clean)
GO_GCFLAGS := "all=-trimpath=${PWD}"
GO_ASMFLAGS := "all=-trimpath=${PWD}"
-@@ -44,7 +45,7 @@ GO_LDFLAGS += -extldflags \"${LDFLAGS}\"
+@@ -43,7 +44,7 @@ GO_LDFLAGS += -extldflags \"${LDFLAGS}\"
GO_LDFLAGS += -X $(VERSION_PACKAGE).version=$(VERSION)
GO_LDFLAGS += -X $(VERSION_PACKAGE).buildDate=$(shell date +'%Y-%m-%dT%H:%M:%SZ')
GO_LDFLAGS += -X $(VERSION_PACKAGE).gitCommit=$(COMMIT)