summarylogtreecommitdiffstats
path: root/build_pkgs
diff options
context:
space:
mode:
Diffstat (limited to 'build_pkgs')
-rwxr-xr-xbuild_pkgs50
1 files changed, 0 insertions, 50 deletions
diff --git a/build_pkgs b/build_pkgs
deleted file mode 100755
index 53dacc708eb9..000000000000
--- a/build_pkgs
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/bash
-# default config
-# default build arches
-DEFAULT_CPU_ARCHES=(generic ivybridge skylake broadwell silvermont)
-
-
-build_pkg()
-{
- echo 'source+=(batch_opts)' >> PKGBUILD
- updpkgsums
- makepkg --cleanbuild
-}
-
-# FIXME maybe check for local changes
-if ! git diff-index --quiet HEAD -- ; then
- echo 'local changes found, please commit first' >&2
- echo 'exit'
- exit 1
-fi
-
-# load local build script if found to apply gpg settings or alike, if existing
-if [ -e build_pkgs.local ] ; then
- source build_pkgs.local
-fi
-
-git checkout .
-
-for cpu in ${*:-${DEFAULT_CPU_ARCHES[*]}} ; do
- git checkout PKGBUILD
- case $cpu in
- generic)
- echo : > batch_opts
- build_pkg
- ;;
- *)
- cat >> PKGBUILD <<EOF
-source+=(batch_opts)
-pkgname=(linux-pf-$cpu)
-eval "package_linux-pf-$cpu() {
- \$(declare -f _package)
- _package
- }"
-EOF
- echo "LCPU=$cpu" > batch_opts
- build_pkg
- ;;
- esac
- git checkout .
-done
-