summarylogtreecommitdiffstats
path: root/build_pkgs
diff options
context:
space:
mode:
Diffstat (limited to 'build_pkgs')
-rwxr-xr-xbuild_pkgs38
1 files changed, 26 insertions, 12 deletions
diff --git a/build_pkgs b/build_pkgs
index 8c9294634243..e3229e3c2eae 100755
--- a/build_pkgs
+++ b/build_pkgs
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/bash -e
# default config
# default build arches
DEFAULT_CPU_ARCHES=(generic generic-v2 generic-v3 generic-v4
@@ -20,7 +20,7 @@ if ! git diff-index --quiet HEAD -- ; then
echo 'exit'
exit 1
fi
-
+
# load local build script if found to apply gpg settings or alike, if existing
if [ -e build_pkgs.local ] ; then
source build_pkgs.local
@@ -32,21 +32,35 @@ for cpu in ${*:-${DEFAULT_CPU_ARCHES[*]}} ; do
git checkout PKGBUILD
case $cpu in
generic)
- echo : > batch_opts
- build_pkg
+ cat >> PKGBUILD <<EOF
+pkgname=(linux-pf-$cpu linux-pf-headers-variant-$cpu linux-pf-headers)
+EOF
;;
- *)
+ *)
cat >> PKGBUILD <<EOF
-pkgname=(linux-pf-$cpu)
-eval "package_linux-pf-$cpu() {
- \$(declare -f _package)
- _package
- }"
+pkgname=(linux-pf-$cpu linux-pf-headers-variant-$cpu)
EOF
- echo "LCPU=$cpu" > batch_opts
- build_pkg
;;
esac
+
+ cat >> PKGBUILD <<EOF
+eval "package_linux-pf-headers-variant-$cpu() {
+ \$(declare -f "_package-headers-variant")
+ _package-headers-variant
+ }"
+eval "package_linux-pf-$cpu() {
+ \$(declare -f "_package")
+ _package
+ }"
+EOF
+ echo "LCPU=$cpu" > batch_opts
+
+ build_pkg
+
git checkout .
done
+# eval "package_linux-pf-$cpu() {
+# \$(declare -f _package)
+# _package
+# }"