summarylogtreecommitdiffstats
path: root/cflags-order.patch
diff options
context:
space:
mode:
Diffstat (limited to 'cflags-order.patch')
-rw-r--r--cflags-order.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/cflags-order.patch b/cflags-order.patch
new file mode 100644
index 000000000000..4a07647d3732
--- /dev/null
+++ b/cflags-order.patch
@@ -0,0 +1,22 @@
+ Makefile | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git c/Makefile i/Makefile
+index 8e4ca56..e6ad0af 100644
+--- c/Makefile
++++ i/Makefile
+@@ -130,10 +130,10 @@ else
+ $(TOP_DIR)/include \
+ $(SRC_DIR)
+
+- COMPILE = $(CC) $(CPPFLAGS) \
+- $(CFLAGS) \
+- $(ANSIFLAGS) \
+- $(INCLUDES:%=$I%)
++ COMPILE = $(CC) $(ANSIFLAGS) \
++ $(INCLUDES:%=$I%) \
++ $(CPPFLAGS) \
++ $(CFLAGS)
+
+ # Enable C99 for gcc to avoid warnings.
+ # Note that clang++ aborts with an error if we use `-std=C99',