summarylogtreecommitdiffstats
path: root/check_mk.install
diff options
context:
space:
mode:
Diffstat (limited to 'check_mk.install')
-rw-r--r--check_mk.install27
1 files changed, 17 insertions, 10 deletions
diff --git a/check_mk.install b/check_mk.install
index ec7958743994..572eb1f536c9 100644
--- a/check_mk.install
+++ b/check_mk.install
@@ -1,16 +1,23 @@
post_install() {
- echo " ==> Check_MF is now installed."
+ echo " ==> Check_MK is now installed."
echo " ==> To use it, please do the following steps:"
- echo " 1. Edit /etc/check_mk/main.mk and add your hosts."
- echo " 2. Install the check_mk_agent and start xinetd on every host."
- echo " 3. Run cmk -I to autodetect services on the hosts."
+ echo " 1. Setup nagios (see wiki) and make sure it's working."
+ echo " 2. Don't forget to add the user \"http\" to the group \"nagios\":"
+ echo " usermod -G nagios -a http"
+ echo " 3. Install the check_mk_agent and start xinetd on every host."
echo " 4. Run check_mk -O to generate /etc/nagios/objects/check_mk_objects.cfg"
echo " 5. Add the following lines to your /etc/nagios/nagios.cfg:"
- echo " cfg_file=/etc/nagios/objects/check_mk_objects.cfg"
echo " cfg_file=/etc/nagios/objects/check_mk_templates.cfg"
- echo " 6. Add the following line to your /etc/httpd/conf/httpd.conf:"
- echo " Include conf/extra/zzz_check_mk.conf"
- echo " 7. Add the user your webserver is running as to the nagios group."
- echo " 8. Configure mod_python."
- echo " 9. Restart your webserver and nagios."
+ echo " cfg_file=/etc/nagios/objects/check_mk_objects.cfg"
+ echo " broker_module=/usr/lib/check_mk/livestatus.o /var/nagios/rw/live"
+ echo " 6. Copy or symlink /etc/webapps/check_mk/apache.example.conf"
+ echo " to /etc/httpd/conf/extra/check_mk.conf and include the following"
+ echo " following line to your /etc/httpd/conf/httpd.conf:"
+ echo " Include conf/extra/check_mk.conf"
+ echo " 7. Configure mod_python2:"
+ echo " Add the following line to /etc/httpd/conf/httpd.conf:"
+ echo " LoadModule python_module modules/mod_python.so"
+ echo " 8. Restart your webserver and nagios:"
+ echo " systemctl restart httpd"
+ echo " systemctl restart nagios"
}