summarylogtreecommitdiffstats
path: root/cmake-wallet.patch
diff options
context:
space:
mode:
Diffstat (limited to 'cmake-wallet.patch')
-rw-r--r--cmake-wallet.patch77
1 files changed, 77 insertions, 0 deletions
diff --git a/cmake-wallet.patch b/cmake-wallet.patch
new file mode 100644
index 000000000000..434afac01583
--- /dev/null
+++ b/cmake-wallet.patch
@@ -0,0 +1,77 @@
+diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
+index 63908005..16230545 100644
+--- a/src/wallet/CMakeLists.txt
++++ b/src/wallet/CMakeLists.txt
+@@ -86,42 +86,40 @@ target_link_libraries(wallet
+ ${EXTRA_LIBRARIES})
+ add_dependencies(wallet version)
+
+-if (NOT BUILD_GUI_DEPS)
+- set(wallet_rpc_sources
+- wallet_rpc_server.cpp)
++set(wallet_rpc_sources
++ wallet_rpc_server.cpp)
+
+- set(wallet_rpc_headers)
++set(wallet_rpc_headers)
+
+- set(wallet_rpc_private_headers
+- wallet_rpc_server.h)
++set(wallet_rpc_private_headers
++ wallet_rpc_server.h)
+
+- monero_private_headers(wallet_rpc_server
+- ${wallet_rpc_private_headers})
+- monero_add_executable(wallet_rpc_server
+- ${wallet_rpc_sources}
+- ${wallet_rpc_headers}
+- ${wallet_rpc_private_headers})
++monero_private_headers(wallet_rpc_server
++ ${wallet_rpc_private_headers})
++monero_add_executable(wallet_rpc_server
++ ${wallet_rpc_sources}
++ ${wallet_rpc_headers}
++ ${wallet_rpc_private_headers})
+
+- target_link_libraries(wallet_rpc_server
+- PRIVATE
+- wallet
+- epee
+- rpc
+- cryptonote_core
+- cncrypto
+- common
+- ${Boost_CHRONO_LIBRARY}
+- ${Boost_PROGRAM_OPTIONS_LIBRARY}
+- ${Boost_FILESYSTEM_LIBRARY}
+- ${Boost_THREAD_LIBRARY}
+- ${CMAKE_THREAD_LIBS_INIT}
+- ${EXTRA_LIBRARIES})
+- add_dependencies(wallet_rpc_server version)
+- set_property(TARGET wallet_rpc_server
+- PROPERTY
+- OUTPUT_NAME "monero-wallet-rpc")
+- install(TARGETS wallet_rpc_server DESTINATION bin)
+-endif()
++target_link_libraries(wallet_rpc_server
++ PRIVATE
++ wallet
++ epee
++ rpc
++ cryptonote_core
++ cncrypto
++ common
++ ${Boost_CHRONO_LIBRARY}
++ ${Boost_PROGRAM_OPTIONS_LIBRARY}
++ ${Boost_FILESYSTEM_LIBRARY}
++ ${Boost_THREAD_LIBRARY}
++ ${CMAKE_THREAD_LIBS_INIT}
++ ${EXTRA_LIBRARIES})
++add_dependencies(wallet_rpc_server version)
++set_property(TARGET wallet_rpc_server
++ PROPERTY
++ OUTPUT_NAME "monero-wallet-rpc")
++install(TARGETS wallet_rpc_server DESTINATION bin)
+
+
+ # build and install libwallet_merged only if we building for GUI