summarylogtreecommitdiffstats
path: root/cmake_boost.patch
diff options
context:
space:
mode:
Diffstat (limited to 'cmake_boost.patch')
-rw-r--r--cmake_boost.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/cmake_boost.patch b/cmake_boost.patch
new file mode 100644
index 000000000000..4ddad6acf001
--- /dev/null
+++ b/cmake_boost.patch
@@ -0,0 +1,13 @@
+diff --git CMakeLists.txt CMakeLists.txt
+index 10969c2..dd28028 100644
+--- e4rat-lite/CMakeLists.txt
++++ e4rat-lite/CMakeLists.txt
+@@ -20,7 +20,7 @@ IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+ ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+
+ set(Boost_USE_STATIC_LIBS OFF)
+-set(Boost_USE_MULTITHREADED OFF)
++set(Boost_USE_MULTITHREADED ON)
+ find_package(Boost 1.41 COMPONENTS system filesystem regex REQUIRED)
+ set(${PROJECT_NAME}_LIBRARIES ${${PROJECT_NAME}_LIBRARIES}
+ ${Boost_LIBRARIES})