summarylogtreecommitdiffstats
path: root/configure-cross.patch
diff options
context:
space:
mode:
Diffstat (limited to 'configure-cross.patch')
-rw-r--r--configure-cross.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure-cross.patch b/configure-cross.patch
new file mode 100644
index 000000000000..13680cc0a697
--- /dev/null
+++ b/configure-cross.patch
@@ -0,0 +1,24 @@
+--- sqlite-src-3370000/configure.ac.old 2021-12-05 22:29:52.509814861 +0300
++++ sqlite-src-3370000/configure.ac 2021-12-05 22:53:06.317941047 +0300
+@@ -258,14 +258,16 @@
+ fi
+ if test "$CYGWIN" = "yes"; then
+ BUILD_EXEEXT=.exe
+-else
+- BUILD_EXEEXT=$EXEEXT
+ fi
++
+ if test x"$cross_compiling" = xno; then
+- TARGET_EXEEXT=$BUILD_EXEEXT
+-else
+- TARGET_EXEEXT=$config_TARGET_EXEEXT
++ BUILD_EXEEXT=$EXEEXT
++fi
++
++if test -z "$TARGET_EXEEXT"; then
++ TARGET_EXEEXT=$EXEEXT
+ fi
++
+ if test "$TARGET_EXEEXT" = ".exe"; then
+ SQLITE_OS_UNIX=0
+ SQLITE_OS_WIN=1