summarylogtreecommitdiffstats
path: root/configure-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'configure-fix.patch')
-rw-r--r--configure-fix.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure-fix.patch b/configure-fix.patch
new file mode 100644
index 000000000000..6dbe30fd75cd
--- /dev/null
+++ b/configure-fix.patch
@@ -0,0 +1,35 @@
+diff -ruN librsvg-2.42.2/configure.ac librsvg-2.42.2-patched/configure.ac
+--- librsvg-2.42.2/configure.ac 2018-01-24 04:21:06.000000000 +0800
++++ librsvg-2.42.2-patched/configure.ac 2018-02-08 00:54:57.209773524 +0800
+@@ -103,6 +103,22 @@
+ AC_MSG_RESULT([$native_win32])
+ AM_CONDITIONAL(OS_WIN32, test "$native_win32" = "yes")
+
++AC_MSG_CHECKING([for rust target])
++case "$host" in
++ i686*-*-mingw*|i686*-*-cygwin*)
++ rust_target=i686-pc-windows-gnu
++ ;;
++ x86_64*-*-mingw*|x86_64*-*-cygwin*)
++ rust_target=x86_64-pc-windows-gnu
++ ;;
++ *)
++ rust_target=$host
++ ;;
++esac
++AC_MSG_RESULT([$rust_target])
++AM_CONDITIONAL(RUST_TARGET, test -n rust_target)
++AC_ARG_VAR(rust_target, [used in cargo --target=])
++
+ dnl ===========================================================================
+
+ GLIB_MKENUMS=`$PKG_CONFIG --variable=glib_mkenums glib-2.0`
+@@ -262,7 +278,7 @@
+
+ AM_CONDITIONAL(CROSS_COMPILING, test $cross_compiling = yes)
+ if test "x$cross_compiling" = "xyes" ; then
+- RUST_TARGET_SUBDIR="$host/$RUST_TARGET_SUBDIR"
++ RUST_TARGET_SUBDIR="$rust_target/$RUST_TARGET_SUBDIR"
+ fi
+ AC_SUBST([RUST_TARGET_SUBDIR])
+