summarylogtreecommitdiffstats
path: root/ddb_discord_presence-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'ddb_discord_presence-makefile.patch')
-rw-r--r--ddb_discord_presence-makefile.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/ddb_discord_presence-makefile.patch b/ddb_discord_presence-makefile.patch
new file mode 100644
index 000000000000..473e0e050112
--- /dev/null
+++ b/ddb_discord_presence-makefile.patch
@@ -0,0 +1,14 @@
+diff -r -u -N ddb_discord_presence/Makefile ddb_discord_presence-makefile/Makefile
+--- ddb_discord_presence/Makefile 2018-09-30 15:14:26.874053581 +0200
++++ ddb_discord_presence-makefile/Makefile 2018-09-30 15:15:45.258372163 +0200
+@@ -8,8 +8,8 @@
+ CC=gcc
+ CXX=g++
+ STD=gnu99
+-CFLAGS+=-fPIC -I /usr/local/include -I discord-rpc/include -Wall
+-CXXFLAGS+=-fPIC -I /usr/local/include -Wall
++CFLAGS+=$(COPT) -fPIC -I /usr/local/include -I discord-rpc/include -Wall
++CXXFLAGS+=$(CXXOPT) -fPIC -I /usr/local/include -Wall
+ ifeq ($(DEBUG),1)
+ CFLAGS +=-g -O0
+ CXXFLAGS +=-g -O0