summarylogtreecommitdiffstats
path: root/debianize.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debianize.patch')
-rw-r--r--debianize.patch56
1 files changed, 28 insertions, 28 deletions
diff --git a/debianize.patch b/debianize.patch
index 51e73ff5cfb7..a63db116595e 100644
--- a/debianize.patch
+++ b/debianize.patch
@@ -5,25 +5,10 @@ Description: adjust where files are installed, which seems specific to Debian.
Author: Kees Cook <kees@debian.org>
Forwarded: not-needed
-Index: dosemu-1.4.0+svn.2080/src/emu.c
-===================================================================
---- dosemu-1.4.0+svn.2080.orig/src/emu.c 2012-06-16 11:51:59.000000000 -0700
-+++ dosemu-1.4.0+svn.2080/src/emu.c 2012-06-16 11:54:53.960920640 -0700
-@@ -245,8 +245,8 @@
- ".\nCopyright (C) 1992-2006 the 'DOSEMU-Development-Team'.\n"
- "This program is distributed in the hope that it will be useful,\n"
- "but WITHOUT ANY WARRANTY; without even the implied warranty of\n"
-- "MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the files\n"
-- "COPYING.DOSEMU and COPYING for more details.\n"
-+ "MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the file\n"
-+ "/usr/share/doc/dosemu/copyright for more details.\n"
- "Use this program at your own risk!\n\n";
-
- static char text2[] =
-Index: dosemu-1.4.0+svn.2080/src/arch/linux/Makefile.main
-===================================================================
---- dosemu-1.4.0+svn.2080.orig/src/arch/linux/Makefile.main 2012-06-16 11:51:59.000000000 -0700
-+++ dosemu-1.4.0+svn.2080/src/arch/linux/Makefile.main 2012-06-16 11:54:53.968920748 -0700
+diff --git a/src/arch/linux/Makefile.main b/src/arch/linux/Makefile.main
+index 793c9e2..c25ead3 100644
+--- a/src/arch/linux/Makefile.main
++++ b/src/arch/linux/Makefile.main
@@ -9,7 +9,7 @@
# install DOSEMU.
@@ -33,7 +18,7 @@ Index: dosemu-1.4.0+svn.2080/src/arch/linux/Makefile.main
NET=dosext/net/net
-@@ -196,7 +196,6 @@
+@@ -215,7 +215,6 @@ install:
$(INSTALL) -d $(DESTDIR)$(bindir)
$(INSTALL) -m 0755 ../bin/$(DOSBIN) $(DESTDIR)$(bindir)
$(INSTALL) -m 0755 ../bin/dosemu $(DESTDIR)$(bindir)
@@ -41,20 +26,35 @@ Index: dosemu-1.4.0+svn.2080/src/arch/linux/Makefile.main
$(INSTALL) -m 0755 ../bin/mkfatimage16 $(DESTDIR)$(bindir)
ifdef USE_SBEMU
$(INSTALL) -m 0755 ../bin/midid $(DESTDIR)$(bindir)
-@@ -211,7 +210,7 @@
+@@ -230,7 +229,7 @@ endif
fi; \
done
$(INSTALL) -d $(DESTDIR)$(docdir)
-- for i in README.bindist NEWS THANKS COPYING COPYING.DOSEMU; do \
-+ for i in README.bindist NEWS THANKS; do \
+- for i in README.bindist NEWS THANKS COPYING COPYING.DOSEMU BUGS ChangeLog; do \
++ for i in README.bindist NEWS THANKS BUGS ChangeLog; do \
$(INSTALL) -m 0644 $(REALTOPDIR)/$$i $(DESTDIR)$(docdir); \
done
for i in README README-tech dosemu-HOWTO sound-usage DANG EMUfailure \
-Index: dosemu-1.4.0+svn.2080/src/tools/periph/Makefile
-===================================================================
---- dosemu-1.4.0+svn.2080.orig/src/tools/periph/Makefile 2012-06-16 11:51:55.000000000 -0700
-+++ dosemu-1.4.0+svn.2080/src/tools/periph/Makefile 2012-06-16 11:54:53.968920748 -0700
-@@ -11,12 +11,12 @@
+diff --git a/src/emu.c b/src/emu.c
+index 94ffa6a..87c8481 100644
+--- a/src/emu.c
++++ b/src/emu.c
+@@ -248,8 +248,8 @@ void do_liability_disclaimer_prompt(int dosboot, int prompt)
+ ".\nCopyright (C) 1992-2006 the 'DOSEMU-Development-Team'.\n"
+ "This program is distributed in the hope that it will be useful,\n"
+ "but WITHOUT ANY WARRANTY; without even the implied warranty of\n"
+- "MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the files\n"
+- "COPYING.DOSEMU and COPYING for more details.\n"
++ "MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the file\n"
++ "/usr/share/doc/dosemu/copyright for more details.\n"
+ "Use this program at your own risk!\n\n";
+
+ static char text2[] =
+diff --git a/src/tools/periph/Makefile b/src/tools/periph/Makefile
+index 4abff44..a7058b4 100644
+--- a/src/tools/periph/Makefile
++++ b/src/tools/periph/Makefile
+@@ -11,12 +11,12 @@ include $(top_builddir)/Makefile.conf
D=$(REALTOPDIR)/etc
IDEST=/var/lib