summarylogtreecommitdiffstats
path: root/destdir-support-20140329-1.patch
diff options
context:
space:
mode:
Diffstat (limited to 'destdir-support-20140329-1.patch')
-rw-r--r--destdir-support-20140329-1.patch58
1 files changed, 17 insertions, 41 deletions
diff --git a/destdir-support-20140329-1.patch b/destdir-support-20140329-1.patch
index 408dd9ff594f..972bcb3ef43e 100644
--- a/destdir-support-20140329-1.patch
+++ b/destdir-support-20140329-1.patch
@@ -1,18 +1,6 @@
-Maintainer: Nicola Bignami <nicola@kernel-panic.dnsdojo.net>
-Contributor: Muhammed Uluyol <uluyol0@gmail.com>
-Subject: [PATCH] Destdir support
-
--- a/Makefile
+++ b/Makefile
-@@ -18,7 +18,6 @@ VERSION=0.0
-
- # Installation prefix...
- PREFIX=/usr/local
--PREFIX=/usr
- PREFIX=$(DESTDIR)/usr
-
- # Pathnames for this package...
-@@ -38,7 +37,7 @@ INSTALL=install
+@@ -38,7 +38,7 @@
ROOT=root
# Pathnames for referenced packages...
@@ -21,26 +9,19 @@ Subject: [PATCH] Destdir support
# User ID's
LPuid=-oroot
-@@ -249,7 +250,7 @@ # CUPS vars
+@@ -245,8 +245,9 @@
+
+ # CUPS vars
CUPS_SERVERBIN := $(DESTDIR)$(shell cups-config --serverbin 2>/dev/null)
-CUPS_DEVEL := $(shell grep cupsSideChannelDoRequest /usr/include/cups/sidechannel.h 2>/dev/null)
-+CUPS_DEVEL := $(DESTDIR)$(shell grep cupsSideChannelDoRequest /usr/include/cups/sidechannel.h 2>/dev/null)
-CUPS_GOODAPI := $(shell cups-config --api-version 2>/dev/null | sed "s/1\.[0123].*//")
-+CUPS_GOODAPI := $(DESTDIR)$(shell cups-config --api-version | sed "s/1\.[0123].*//" 2>/dev/null)
++CUPS_DEVEL := $(DESTDIR)$(shell grep cupsSideChannelDoRequest /usr/include/cups/sidechannel.h 2>/dev/null)
++CUPS_GOODAPI := $(DESTDIR)$(shell cups-config --api-version 2>/dev/null | sed "s/1\.[0123].*//")
++
# hpclj2600n-0.icm km2430_0.icm km2430_1.icm km2430_2.icm samclp300-0.icm
# sihp1000.img sihp1005.img sihp1020.img sihp1018.img
- # sihpP1005.img sihpP1006.img sihpP1505.img
-@@ -654,6 +657,8 @@ install-test:
- UDEVBIN=$(DESTDIR)/bin/
-
- install-prog:
-+ [ -d $(BIN) ] || $(INSTALL) -d -m 755 $(BIN)/
-+ [ -d $(DESTDIR)/usr/bin/ ] || $(INSTALL) -d -m 755 $(DESTDIR)/usr/bin/
- #
- # Install driver, wrapper, and development tools
- #
-@@ -661,7 +658,7 @@ install-prog:
+@@ -652,7 +653,7 @@
$(INSTALL) -c $(PROGS) $(SHELLS) $(BIN)/
if [ "$(BINPROGS)" != "" ]; then \
$(INSTALL) -d $(UDEVBIN); \
@@ -49,7 +30,7 @@ Subject: [PATCH] Destdir support
fi
#
# Install gamma correction files. These are just templates,
-@@ -715,10 +722,10 @@ install-foo:
+@@ -706,10 +707,10 @@
#
# Clear foomatic cache and rebuild database if needed
#
@@ -64,34 +45,29 @@ Subject: [PATCH] Destdir support
foomatic-combo-xml -O >overview.xml; \
fi
-@@ -847,10 +854,10 @@ install-extra:
- fi; \
+@@ -839,7 +840,7 @@
done
--MODEL=$(DESTDIR)/usr/share/cups/model
-+MODEL=$(PREFIX)/share/cups/model
+ MODEL=$(PREFIX)/share/cups/model
-LOCALMODEL=$(DESTDIR)/usr/local/share/cups/model
+LOCALMODEL=$(PREFIX)/usr/local/share/cups/model
MACMODEL=/Library/Printers/PPDs/Contents/Resources
--PPD=$(DESTDIR)/usr/share/ppd
-+PPD=$(PREFIX)/share/ppd
+ PPD=$(PREFIX)/share/ppd
VARPPD=/var/lp/ppd
- install-ppd:
- #
-@@ -908,9 +908,9 @@ install-ppd:
+@@ -899,9 +900,9 @@
done; \
fi
-APPL=$(DESTDIR)/usr/share/applications
-OLDAPPL=$(DESTDIR)/usr/share/gnome/apps/System
-PIXMAPS=$(DESTDIR)/usr/share/pixmaps
-+APPL=$(PREFIX)/share/applications
-+OLDAPPL=$(PREFIX)/share/gnome/apps/System
-+PIXMAPS=$(PREFIX)/share/pixmaps
++APPL=$(PREFIX)/usr/share/applications
++OLDAPPL=$(PREFIX)/usr/share/gnome/apps/System
++PIXMAPS=$(PREFIX)/usr/share/pixmaps
install-desktop:
#
-@@ -934,7 +934,7 @@ install-gui:
+@@ -925,7 +926,7 @@
$(INSTALL) -c -m 755 hplj10xx_gui.tcl $(SHAREZJS)