summarylogtreecommitdiffstats
path: root/directories.patch
diff options
context:
space:
mode:
Diffstat (limited to 'directories.patch')
-rw-r--r--directories.patch15
1 files changed, 8 insertions, 7 deletions
diff --git a/directories.patch b/directories.patch
index 5eac963dfb05..85af03ad00af 100644
--- a/directories.patch
+++ b/directories.patch
@@ -1,15 +1,16 @@
---- openclonk-release-6.0-src/CMakeLists.txt 2015-03-12 22:21:51.000000000 +0100
-+++ openclonk-release-6.0-src.new/CMakeLists.txt 2015-03-15 20:57:35.333928593 +0100
-@@ -1215,7 +1215,7 @@
+diff -aur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2016-01-15 21:56:57.000000000 +0100
++++ b/CMakeLists.txt 2016-01-17 20:48:52.194153030 +0100
+@@ -100,7 +100,7 @@
# Don't put this into CMAKE_CXX_FLAGS because otherwise it is cached,
# and when the path is changed both the old and new definition appears
# in the list of flags.
- add_definitions("-DOC_SYSTEM_DATA_DIR=\"${CMAKE_INSTALL_PREFIX}/share/games/openclonk\"")
+ add_definitions("-DOC_SYSTEM_DATA_DIR=\"${CMAKE_INSTALL_PREFIX}/share/openclonk\"")
endif()
- if(OC_CXX_FLAGS)
- list(REMOVE_DUPLICATES OC_CXX_FLAGS)
-@@ -1537,7 +1537,7 @@
+
+ if(APPLE)
+@@ -1461,7 +1461,7 @@
DEPENDS "${native_c4group}"
VERBATIM
)
@@ -18,7 +19,7 @@
endif()
endforeach()
-@@ -1551,7 +1551,7 @@
+@@ -1475,7 +1475,7 @@
install(CODE "execute_process(COMMAND update-desktop-database)")
# Install binaries