summarylogtreecommitdiffstats
path: root/disable-debian.patch
diff options
context:
space:
mode:
Diffstat (limited to 'disable-debian.patch')
-rw-r--r--disable-debian.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/disable-debian.patch b/disable-debian.patch
new file mode 100644
index 000000000000..0d9424a49d7a
--- /dev/null
+++ b/disable-debian.patch
@@ -0,0 +1,32 @@
+diff -cr cbftp-r1011.o/Makefile.inc cbftp-r1011/Makefile.inc
+*** cbftp-r1011.o/Makefile.inc 2019-03-17 04:15:01.000000000 -0500
+--- cbftp-r1011/Makefile.inc 2019-03-31 21:46:53.009762000 -0500
+***************
+*** 38,42 ****
+ ifeq ($(UNAME_S),Darwin)
+ LINKFLAGS+=-lncurses
+ else
+! LINKFLAGS+=-lncursesw
+ endif
+--- 38,42 ----
+ ifeq ($(UNAME_S),Darwin)
+ LINKFLAGS+=-lncurses
+ else
+! LINKFLAGS+=-lncurses
+ endif
+diff -cr cbftp-r1011.o/src/ui/ncurseswrap.h cbftp-r1011/src/ui/ncurseswrap.h
+*** cbftp-r1011.o/src/ui/ncurseswrap.h 2019-03-17 04:15:01.000000000 -0500
+--- cbftp-r1011/src/ui/ncurseswrap.h 2019-03-31 22:05:16.467017954 -0500
+***************
+*** 4,8 ****
+ #ifdef __APPLE__
+ #include <ncurses.h>
+ #else
+! #include <ncursesw/curses.h>
+ #endif
+--- 4,8 ----
+ #ifdef __APPLE__
+ #include <ncurses.h>
+ #else
+! #include <ncurses.h>
+ #endif